qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brandon Pedersen <bped...@gmail.com>
Subject problems using cqpid with java broker
Date Fri, 10 Feb 2012 06:20:51 GMT
Hi, I am currently using the C++ broker with the python cqpid client
and it is running smoothly. However, after reading through this
http://qpid.2158936.n2.nabble.com/DerbyDB-vs-BerkeleyDB-using-the-Java-Broker-tp7056640p7155540.html
I thought it would be best to switch to the Java broker instead. I am
currently using 0.12 but am testing out the 0.14 java broker (though
the same problem I am having exists with 0.12). When I try to use the
cqpid client with the Java broker it does not work. My python program
spits out a ton of messages like "warning Connection
[127.0.0.1:48782-localhost:5672] closed" and basically hangs...I have
to force kill it. And on the server it outputs the following over and
over again:

2012-02-08 22:22:53,592 INFO  [IoReceiver - /127.0.0.1:33357]
logging.Log4jMessageLogger (Log4jMessageLogger.java:72) -
[con:458(/127.0.0.1:33357)] CON-1001 : Open : Protocol Version : 0-10
2012-02-08 22:22:53,592 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - RECV: [conn:5dfa490] AMQP.1 0-10
2012-02-08 22:22:53,593 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - SEND: [conn:5dfa490] AMQP.1 0-10
2012-02-08 22:22:53,593 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - SEND: [conn:5dfa490] ch=0
ConnectionStart(serverProperties={qpid.federation_tag=957f527c-dfa5-4192-8160-9f092b31b303},
mechanisms=[AMQPLAIN, PLAIN, CRAM-MD5], locales=[en_US])
2012-02-08 22:22:53,593 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - FLUSH: [conn:5dfa490]
2012-02-08 22:22:53,594 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - RECV: [conn:5dfa490] ch=0
ConnectionStartOk(clientProperties={qpid.client_pid=18119,
qpid.client_ppid=28800, qpid.client_process=python,
qpid.session_flow=1}, mechanism=, response=[B@1dacecf3, locale=en_US)
2012-02-08 22:22:53,594 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - SEND: [conn:5dfa490] ch=0
ConnectionTune(channelMax=256, maxFrameSize=65535, heartbeatMin=0,
heartbeatMax=0)
2012-02-08 22:22:53,594 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - FLUSH: [conn:5dfa490]
2012-02-08 22:22:53,595 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - RECV: [conn:5dfa490] ch=0
ConnectionTuneOk(channelMax=256, maxFrameSize=65535, heartbeat=0)
2012-02-08 22:22:53,595 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - RECV: [conn:5dfa490] ch=0
ConnectionOpen(virtualHost=, capabilities=[], insist=true)
2012-02-08 22:22:53,596 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - SEND: [conn:5dfa490] ch=0
ConnectionOpenOk(knownHosts=[])
2012-02-08 22:22:53,596 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - FLUSH: [conn:5dfa490]
2012-02-08 22:22:53,597 INFO  [IoReceiver - /127.0.0.1:33357]
logging.Log4jMessageLogger (Log4jMessageLogger.java:72) -
[con:458(/127.0.0.1:33357)] CON-1001 : Open : Client ID : null :
Protocol Version : 0-10
2012-02-08 22:22:53,597 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - RECV: [conn:5dfa490] ch=1
SessionAttach(name=[B@64836727)
2012-02-08 22:22:53,597 DEBUG [IoReceiver - /127.0.0.1:33357]
util.Logger (Logger.java:54) - connection closed: conn:5dfa490

Any idea what might be wrong here? Is this a bug or am I potentially
doing something wrong?

Thanks,

-Brandon

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message