qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Qpid 0.12 make install fails :-(
Date Sun, 27 Nov 2011 19:54:54 GMT
Hi again,
I've got a bit further making Qpid 0.12 on my Ubuntu box so I'm now 
trying make install.

Unfortunately I'm bombing out with.

/bin/bash ../libtool   --mode=install /usr/bin/install -c   cluster.la 
watchdog.la acl.la xml.la replicating_listener.la 
replication_exchange.la '/usr/local/lib/qpid/daemon'
libtool: install: warning: relinking `cluster.la'
libtool: install: (cd /home/fadams/java/qpid-0.12/cpp/src; /bin/bash 
/home/fadams/java/qpid-0.12/cpp/libtool  --tag CXX --mode=relink g++ 
-Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual 
-Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch 
-Wno-system-headers -Woverloaded-virtual 
-DQPID_LIBEXEC_DIR=\"/usr/local/libexec/qpid\" 
-DBOOST_FILESYSTEM_VERSION=2 -fno-strict-aliasing -g -O2 -no-undefined 
-module -avoid-version -L/usr/lib/openais -L/usr/lib64/openais 
-L/usr/lib/corosync -L/usr/lib64/corosync -o cluster.la -rpath 
/usr/local/lib/qpid/daemon qpid/cluster/cluster_la-Quorum_cman.lo 
qpid/cluster/cluster_la-Cluster.lo 
qpid/cluster/cluster_la-ClusterTimer.lo 
qpid/cluster/cluster_la-Decoder.lo qpid/cluster/cluster_la-ClusterMap.lo 
qpid/cluster/cluster_la-ClusterPlugin.lo 
qpid/cluster/cluster_la-Connection.lo 
qpid/cluster/cluster_la-ConnectionCodec.lo 
qpid/cluster/cluster_la-Cpg.lo qpid/cluster/cluster_la-UpdateClient.lo 
qpid/cluster/cluster_la-RetractClient.lo 
qpid/cluster/cluster_la-ErrorCheck.lo qpid/cluster/cluster_la-Event.lo 
qpid/cluster/cluster_la-EventFrame.lo 
qpid/cluster/cluster_la-ExpiryPolicy.lo 
qpid/cluster/cluster_la-FailoverExchange.lo 
qpid/cluster/cluster_la-UpdateExchange.lo 
qpid/cluster/cluster_la-Multicaster.lo 
qpid/cluster/cluster_la-OutputInterceptor.lo 
qpid/cluster/cluster_la-PollerDispatch.lo 
qpid/cluster/cluster_la-InitialStatusMap.lo 
qpid/cluster/cluster_la-MemberSet.lo 
qpid/cluster/cluster_la-SecureConnectionFactory.lo 
qpid/cluster/cluster_la-StoreStatus.lo 
qpid/cluster/cluster_la-UpdateDataExchange.lo -lcpg -lcman 
libqpidbroker.la libqpidclient.la )
libtool: relink: g++ -shared -nostdlib 
/usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../../lib/crti.o 
/usr/lib/gcc/x86_64-linux-gnu/4.4.1/crtbeginS.o  
qpid/cluster/.libs/cluster_la-Quorum_cman.o 
qpid/cluster/.libs/cluster_la-Cluster.o 
qpid/cluster/.libs/cluster_la-ClusterTimer.o 
qpid/cluster/.libs/cluster_la-Decoder.o 
qpid/cluster/.libs/cluster_la-ClusterMap.o 
qpid/cluster/.libs/cluster_la-ClusterPlugin.o 
qpid/cluster/.libs/cluster_la-Connection.o 
qpid/cluster/.libs/cluster_la-ConnectionCodec.o 
qpid/cluster/.libs/cluster_la-Cpg.o 
qpid/cluster/.libs/cluster_la-UpdateClient.o 
qpid/cluster/.libs/cluster_la-RetractClient.o 
qpid/cluster/.libs/cluster_la-ErrorCheck.o 
qpid/cluster/.libs/cluster_la-Event.o 
qpid/cluster/.libs/cluster_la-EventFrame.o 
qpid/cluster/.libs/cluster_la-ExpiryPolicy.o 
qpid/cluster/.libs/cluster_la-FailoverExchange.o 
qpid/cluster/.libs/cluster_la-UpdateExchange.o 
qpid/cluster/.libs/cluster_la-Multicaster.o 
qpid/cluster/.libs/cluster_la-OutputInterceptor.o 
qpid/cluster/.libs/cluster_la-PollerDispatch.o 
qpid/cluster/.libs/cluster_la-InitialStatusMap.o 
qpid/cluster/.libs/cluster_la-MemberSet.o 
qpid/cluster/.libs/cluster_la-SecureConnectionFactory.o 
qpid/cluster/.libs/cluster_la-StoreStatus.o 
qpid/cluster/.libs/cluster_la-UpdateDataExchange.o   -L/usr/lib/openais 
-L/usr/lib64/openais -L/usr/lib/corosync -L/usr/lib64/corosync -lcpg 
-lcman -L/usr/local/lib -lqpidbroker -lqpidclient 
-L/usr/lib/gcc/x86_64-linux-gnu/4.4.1 
-L/usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../../lib -L/lib/../lib 
-L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../.. 
-lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-linux-gnu/4.4.1/crtendS.o 
/usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../../lib/crtn.o    
-Wl,-soname -Wl,cluster.so -o .libs/cluster.so
/usr/bin/ld: cannot find -lqpidbroker
collect2: ld returned 1 exit status
libtool: install: error: relink `cluster.la' with the above command 
before installing it
make[3]: *** [install-dmoduleexecLTLIBRARIES] Error 1
make[3]: Leaving directory `/home/fadams/java/qpid-0.12/cpp/src'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/fadams/java/qpid-0.12/cpp/src'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/fadams/java/qpid-0.12/cpp/src'
make: *** [install-recursive] Error 1



It's clearly a dependency issue but my knowledge of automake etc. is 
minimal. In previous installs (for qpid 0.8 and 0.10) I had a similar 
issue where it broke relinking qmf stuff (I might yet get to that point) 
in that case I hacked qmf.mk to rearrange the order of libqmfengine.la - 
I'm thinking that I might have to do the same with cluster.mk but that's 
a lot more complex than qmf.mk so wouldn't know where to begin - there 
must be a better way.

Has anyone actually got qpid 0.12 to install on an Ubuntu box?

This is getting tiresome :-( 0.12 is definitely causing me more pain 
that 0.8 or 0.10 did....

Fraser.





---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message