qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Re: Authentication newbie help sought - I'm afraid I'm failing at the first hurdle :-(
Date Fri, 07 Oct 2011 08:48:36 GMT

>> This looks exactly like I'm seeing, so I'm concerned that 
>> "--sasl-config" is
>> broken on Ubuntu as is the path to the "default" qpidd.conf
>
> Could this be https://issues.apache.org/jira/browse/QPID-3528? I.e. 
> the usage statement is incorrect for that option - you actually need 
> to set it to /etc/sasl2/ in your case (i.e. the path not the file 
> itself)?
>
I don't know whether to laugh or cry :-)

Thanks Gordon that does the trick, though I need an ice pack for my head 
now after banging it against the wall for the last day or so :-D I think 
this is what's known as "character building".

BTW the Jira says

"man pages of qpid are correct:
--sasl-config DIR"

But I've just tried man qpidd on my system (for 0.10 broker) and got

      --sasl-config FILE
              gets sasl config from nonstandard location


Are there any plans to make the trace logging in this area more useful?
Clearly qpidd --sasl-config /home/fadams/qpidd.conf didn't work, but 
there was no indication that it had failed to read the sasl qpidd.conf, 
similarly I tried temporarily renaming qpidd.sasldb and that failed (as 
expected), but there's nothing in the trace logs to suggest that qpidd 
couldn't find the qpidd.sasldb specified in the qpidd.conf

Cheers,
Frase







---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message