qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno França <bru...@digirati.com.br>
Subject Qpid-tools and SSL certificates
Date Tue, 04 Oct 2011 22:36:14 GMT
Hi,

when I set ssl-require-client-authentication and require-encryption on 
my Qpid C++ broker and try to connect to it using qpid-stat, I get the 
following error:

$ export QPID_SSL_CERT_DB=/path/to/mycert_db
$ export QPID_SSL_CERT_NAME=mycert
$ ./bin/qpid-stat -q amqps://bruno.mz.digirati.com.br
Failed: SSLError - [Errno 1] _ssl.c:499: error:14094412:SSL 
routines:SSL3_READ_BYTES:sslv3 alert bad certificate

Seems like the client certificate is being ignored. Is there a way to 
inform qpid-stat which certificate to use? The above command works if I 
disable ssl-require-client-authentication. I'm using SVN rev 1177431 on 
Ubuntu 11.04 x86_64.

Regards,
Bruno França.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message