qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakub Scholz <ja...@scholz.cz>
Subject Re: Problem with starting qpid cluster - "Failed to initialize CPG.: security (100)"
Date Wed, 17 Aug 2011 15:38:20 GMT
Well, we were trying to go according to the guide, including the
troubleshooting chacklist. But the list seems to describe only how to
get the cluster running using corosync only. We wanted to include cman
in the setup - so that we have the quorum, fencing and so on. So our
corosync is being run by the cman. And as a result, it seems that we
can get the cluster running only under root user and not under the
qpidd user. That's why I assume that the configuration of the
addresses, firewalls etc. are correct. It almost seems to me like the
corosync ignores the uidgid configuration when run by cman.

A colleague of mine is now changing the setup to exclude cman - we
will see whether that helps or not.

Regards
Jakub

On Wed, Aug 17, 2011 at 14:59, Alan Conway <aconway@redhat.com> wrote:
> On 08/16/2011 02:02 PM, Jakub Scholz wrote:
>>
>> Hi Andy,
>>
>> Yes, I'm trying to run it qpidd user:
>>
>> $ id
>> uid=498(qpidd) gid=498(qpidd) groups=498(qpidd)
>>
>
> Try the checklist at https://cwiki.apache.org/qpid/starting-a-cluster.html
>

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message