qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Re: QPID Java Client Library for Java 1.4
Date Mon, 22 Aug 2011 18:32:18 GMT
Just to back up my earlier point have you looked through 
http://java.sun.com/j2se/1.5.0/compatibility.html


Fraser Adams wrote:
> Hi Rishi, Is there a reason that you absolutely have to stick with 
> Java 1.4? TBH it's a bit long in the tooth now and more recent Java 
> versions will give you a lot of benefits.
>
> Would you not be better looking at the components that have specific 
> dependencies on old JVM versions and working around those. It seems to 
> me a fairly high risk strategy basing a system around an old JVM, bear 
> in mind it's not just Qpid that doesn't support Java 1.4 I think that 
> you'll find a wide range of commercial (and other Open Source) 
> offerings that have ceased support for Java 1.4, so even if you could 
> work around a Qpid dependency you'll almost certainly come across 
> another before long. IMHO you're going about this the wrong way and 
> you should be looking for ways to get your errant dependencies working 
> with a later JVM version rather than looking at the lowest common 
> denominator.
>
> Just my 2p worth...
>
> Cheers
> Frase
>
>
> Rishi Dev wrote:
>> Thanks for your response Robbie.
>> We will check with our group here and I will come back to the group 
>> in case
>> I need any more help.
>>
>> On Mon, Aug 22, 2011 at 1:00 AM, Robbie Gemmell 
>> <robbie.gemmell@gmail.com>wrote:
>>
>>  
>>> We dont release a Java 1.4 client, no. I believe one was previously
>>> released through use of Retrotranslator, but I'm not sure when the
>>> last one was released; it hasnt been done in years though.
>>>
>>> Regards,
>>> Robbie
>>>
>>> On 22 August 2011 05:50, Rishi Dev <rishdev@gmail.com> wrote:
>>>    
>>>> Hi,
>>>>
>>>> We are having SAPXI in our environment which is on JDK 1.4 and 
>>>> would like
>>>>       
>>> to
>>>    
>>>> integrate it with QPID.
>>>> Please let me know if there is QPID java client library available for
>>>>       
>>> java
>>>    
>>>> 1.4.
>>>>
>>>> I have sent my question, twice earlier also and I am surprised to 
>>>> see no
>>>> response, neither from committers nor from contributors.
>>>> Hope to see this time else we might have to drop QPID out of possible
>>>> options.
>>>>
>>>> Thanks,
>>>> Rishi
>>>>
>>>>       
>>> ---------------------------------------------------------------------
>>> Apache Qpid - AMQP Messaging Implementation
>>> Project:      http://qpid.apache.org
>>> Use/Interact: mailto:users-subscribe@qpid.apache.org
>>>
>>>
>>>     
>>
>>   
>
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>
>


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message