qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: Qpid 0.10 make all fails for me (configure is fine)
Date Thu, 30 Jun 2011 10:03:31 GMT
On 06/30/2011 10:05 AM, fadams wrote:
> Hi guys,
> Thanks for all the help so far - here's an update....
>
> I tried Alan's suggestion "Try moving/removing /usr/include/qpid and
> rebuilding" neat idea, but unfortunately it still barfed.
>
> I then followed Gordon's train of thought about the old 0.8 libraries (my
> 0.8 install is in /usr/local so I just mv'd /usr/local to /usr/xlocal
> temporarily) and the 0.10 make all now works wooo hooo (haven't tried make
> install yet).
>
> So far so good, I can actually build 0.10, but what I really wanted to do
> was to build 0.10 in addition to my 0.8 (we're currently using 0.8
> operationally so I wanted to start playing with 0.10 and
> comparing/regression testing things etc.).
>
> I've just tried putting my /usr/local back and trying the 0.10 build with
> ./configure --prefix=/home/fadams/qpid-0.10-test but unfortunately that
> barfs at the same place as my original problem
>
> I'm thinking that the only way that I can build and install multiple
> versions is to build them both into "non-standard" locations using prefix=

That is the way to go. The build system tries to avoid picking  up stuff from 
the install prefix but clearly it's not 100% successful. Even if you get past 
the build problem you may then run into runtime problems as qpidd tries to load 
configuration from <prefix>/etc and modules from the <prefix>/lib. The make 
check tests are supposed to use --no-module-dir and --no-config-dir to avoid 
this but when running tests by hand its a pain.

> Is anyone else successfully running multiple versions? If so what sort of
> install strategy are you using?

Same thing - different prefixes. In my case I usually have an RPM packaged 
version in /usr and my own build in ~/install. I still manage to shoot myself in 
the foot occasionally by forgetting about external modules (e.g. the msgstore) 
that are hanging around in ~/install/lib from an old build. rm -rf ~/install 
solves the problem.

BTW if you're building and installing a lot you can do make install-exec, which 
doesn't install all the devel headers and so is much faster. (This won't work on 
revisions before 1083077)

Cheers,
Alan.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message