qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Qpid 0.10 make all fails for me (configure is fine)
Date Mon, 27 Jun 2011 17:43:14 GMT
On 06/27/2011 06:33 PM, fadams wrote:
> Hi Alan,
> Thanks for the reply.
>
> The build I attempted was from a download of the full source release from
> the official qpid download page.
>
> Full source release 	qpid-0.10.tar.gz [PGP]
>
> I had to run ./bootstrap to generate the configure script. Then ran
> ./configure followed by make all
>
> If there is a problem with makefile problems I'm sort of surprised it hasn't
> been reported before as I'm doing no more that a basic ./bootstrap
> ./configure make all on the "official" download.
>
> Am I the only one experiencing build problems?
>
> I'm running Ubuntu Studio based on the Karmic release of Ubuntu.
>
> by "Have you tried rebuilding from a completely clean checkout?" do you mean
> taking a subversion checkout.? I haven't tried this - to be honest I'm not
> that confident with subversion so I'm not sure I'd pull the right version -
> is it as simple as doing "svn co http://svn.apache.org/repos/asf/qpid/trunk"
> to get the latest?
>
> Slightly related IIRC when I build 0.8 I had a problem doing make install
> and I had to "hack" qmf.mk a little as libqmfengine.la needed to be before
> libqmf.la otherwise I got a dependency problem I noticed that the order is
> still "wrong" in 0.10 (though I didn't get far enough in the make for this
> to trip me yet)
>
> I'd be grateful for any more pointers and I'm interested to know if it's
> really just me :-)

Do you have an older version installed on the box you are building on? I 
wonder if its picking up an older library somehow.

You could also try the cmake build.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message