qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Nguyen" <thngu...@ign.com>
Subject RE: Node Clustering in v0.6
Date Tue, 30 Nov 2010 19:35:05 GMT
Okay so I fixed it.  The problem was that I compiled the qpid source
before installing openais.  I ran make on the source again and now the
broker has the clustering options.

-----Original Message-----
From: Thomas Nguyen 
Sent: Tuesday, November 30, 2010 11:03 AM
To: users@qpid.apache.org
Subject: RE: Node Clustering in v0.6

I am unable to find cluster.so anywhere in the source or the prefix
directories.  Can you point me in the right direction?

-----Original Message-----
From: Steve Huston [mailto:shuston@riverace.com] 
Sent: Monday, November 22, 2010 5:01 PM
To: users@qpid.apache.org
Subject: RE: Node Clustering in v0.6

Hi Thomas,

> Is clustering available in the version 0.6 of the C++ broker?

Yes, on Linux.
 
>  The qpidd binary does not recognize the "cluster-name" 
> option and does not even mention it in the --help doc.

First, you have to ensure you built the cluster components. If you did,
you need to load the cluster module when running qpidd. If you use the
--load-module /path/to/cluster.so --help you'll get the cluster options.

-Steve

--
Steve Huston, Riverace Corporation
Total Lifecycle Support for Your Networked Applications
http://www.riverace.com


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org



---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message