qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carton <dayda...@gmail.com>
Subject Re: error building persistent store and broker
Date Sun, 19 Sep 2010 13:44:20 GMT
Hi Kim, thanks for your reply.

I'm sorry I didn't describe my problem well.

(1)
The first error occurs when I build the store for the C++ broker 0.6.
The environment are installed C++-0.6-broker, checked-out r3793 store
modules, checked-out HEAD cpp & python & specs modules.
Three HEAD modules are used for configure option --with-qpid-checkout
since ./configure needs qpidd-devel package or these three modules.
(It's CentOS 5.4 I used, and there's no qpidd-devel-0.6 el rpm for
CentOS.)
then i got error as following:
https://docs.google.com/document/pub?id=1U989td_nAjV4BdCtOl1GjIP_LqQ5j1aQONbmkMc44uo&pli=1

(2)
Then I uninstall the C++-0.6-broker and try to build them ALL from
HEAD revision.
So I build broker first but got an error:
[configure works fine]
https://docs.google.com/document/pub?id=18KF4Q58kDeX3Bta1LIhlJMdkjaW0LmmOuZqOnuipojQ

[error when make]
../managementgen/qmf-gen -m ./managementgen.mk -c ./managementgen.cmake -q
-b -o qmf ../../specs/management-schema.xml ./qpid/acl/management-schema.xml
./qpid/cluster/management-schema.xml
: No such file or directory
make[1]: *** [managementgen.mk] Error 127
make[1]: Leaving directory `/tmp/trunk/cpp/src'
make: *** [all-recursive] Error 1
details:
https://docs.google.com/document/pub?id=1URncCNLSZXgbJCWoM6OTn59l7VKodbDjccLM1I3Wv7E

Is it only cpp directory I should check out to build the HEAD revision
of C++ broker?
And it's strange that the files are indeed in the checked-out cpp
directory but it said no. :(



2010/9/17 Kim van der Riet <kim.vdriet@redhat.com>:
> On Fri, 2010-09-17 at 05:50 -0700, David Zhou wrote:
>> I am trying to build the persistent store module r3793 for C++ broker
>> 0.6,
>> and after make by
>> # ./configure --with-qpid-checkout=/tmp
>> (the directories cpp & python & specs under tmp are checkout from HEAD
>> revision
>>  https://svn.apache.org/repos/asf/qpid/trunk/qpid/ )
>>
> The most likely cause of the problem is that you are building an older
> version of the store against a new (in fact, the HEAD) revision of Qpid.
> Because QMF generates code that depends on an exact version of qpid
> being present, the store code is in more-or-less locked to a
> corresponding version of Qpid. The store revision you are building was
> tagged for the 0.6 release of Qpid.
>
> You can either:
>
> Build this version of the store against a build of the 0.6 release of
> Qpid, or
>
> You can build the HEAD version of Qpid against the HEAD version of the
> store.
>
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>
>



-- 
Sincerely,
David

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message