qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yogesh pathade <yogesh_path...@yahoo.co.uk>
Subject Re: QPID Broker not getting messages when used ((XAQueueSession)session1).getQueueSession().createSender(null) for XA from QPID Client
Date Tue, 13 Jul 2010 09:53:29 GMT
Thanks Robert, It saved my debug time. I will take a look into C++ broker.

--- On Tue, 13/7/10, Robert Godfrey <rob.j.godfrey@gmail.com> wrote:

From: Robert Godfrey <rob.j.godfrey@gmail.com>
Subject: Re: QPID Broker not getting messages when used ((XAQueueSession)session1).getQueueSession().createSender(null)
 for XA from QPID Client
To: users@qpid.apache.org
Date: Tuesday, 13 July, 2010, 14:29

Hi Yogesh,

On 12 July 2010 11:51, yogesh pathade <yogesh_pathade@yahoo.co.uk> wrote:
> Hi,
>
>
> I am trying to send Message to queue using QPID Java Broker 0.6.
>
> I am seeing weired behavior when I use the JMS Queue sender for XA
> connection, the sender completes its operation successfully but the JMS
> QPID Broker doesn't receive anything.
>

The Qpid Java Broker does not yet support XA connections - if you need
to use XA you'll have to use the C++ broker at the moment.  The bug
here is that the Java Broker really should fail when you try to create
a session which uses XA - I'll look into that.

Apologies,
Rob

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org




      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message