qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Inoshiro Linden <inosh...@lindenlab.com>
Subject Re: Autoconf problem in persistence module.
Date Tue, 09 Feb 2010 18:13:43 GMT
I nailed down this problem; a case of failing to rtfm:

I had neglected to install pkgconfig (on debian, the "pkg-config" package).


Although this is mentioned in the qpidc-0.5 INSTALL doc, it seems as
if it wasn't necessary for qpidc but it *was* necessary for the
persistence plugin, so I assumed the qpidc prerequisites were already
met.


On Tue, Feb 9, 2010 at 7:31 AM, Kim van der Riet <kim.vdriet@redhat.com> wrote:
> On Fri, 2010-02-05 at 13:09 -0800, Inoshiro Linden wrote:
>> Is this the wrong venue for discussion the C++ persistence plugin?  I
>> am attempting to build revision r3372 to work with the 0.5 qpidc
>> release.
>>
>> There is some problem with autoconf in the persistence module that I don't grok.
>>
>> It's a syntax error in this line:   PKG_CHECK_MODULES(APR, apr-1 >=
>> $APR_MINIMUM_VERSION)
>>
>> This is a /bin/sh script.  So is this an incorrectly unexpanded m4 macro?
>>
>>
>> The relevant trancript follows:
>>
>> cd build/persistence-module-cpp && ./configure --with-qpid-prefix=/usr
>> --prefix=/usr
>
> ...
>
>> ./configure: line 22071: syntax error near unexpected token `APR,'
>> ./configure: line 22071: `  PKG_CHECK_MODULES(APR, apr-1 >=
>> $APR_MINIMUM_VERSION)'
>
> I am not an expert on the autotools...
>
> It is likely that this is related to the versions of autotools in use.
> What are the versions of autoconfig/automake/libtool you are using? I
> have:
>
> automake17-1.7.9-13
> automake16-1.6.3-18
> automake15-1.5-27
> automake14-1.4p6-19
> autoconf-2.63-5
> libtool-2.2.6-17
>
> There may also be distro differences; a lot of what is generated depends
> on what you have installed.  My configure file only has 20658 lines, and
> contains no line such as the one which is giving you problems. I agree
> it looks suspiciously like an autoconf macro that is improperly expanded
> or included in the final script. This macro is not used directly in the
> configure.ac file, however.
>
> I'm assuming you ran bootstrap immediately before, which is responsible
> for generating the configure script.
>
> Here is a thread on a similar issue...
> http://www.mail-archive.com/qpid-dev@incubator.apache.org/msg01941.html.
> This makes me ask if there are old m4 script files lying around? Try a
> fresh checkout without any old builds or previous configurations present
> in the build dir.
>
> Sorry, I have no absolute answers on this.
>
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>
>

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message