qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Ross <tr...@redhat.com>
Subject Re: qpid-route
Date Thu, 05 Nov 2009 15:05:17 GMT
On 11/05/2009 09:02 AM, nicolae claudius wrote:
> Hello,
>
> I use a custom (modified for custom LDAP authentication) qpid broker version 0.4
> I want to use federation between two brokers in Layer 3 network topology, by means of
"qpid-route".
> The problem is that this command is nowhere in my qpid-0.4 source tree, neither in installation
files (make install).
>
> I belive that theese files are in qpid-python project, wich belongs to qpid 0.5 version.
> Is it posible that i use that package to configure federation in my 0.4 broker. If not,
what can I do?
>
> regards,
> Nicolae Claudius
>
> PS.
> The project needs an oficial IRC channel (mabe #qpid on freenode?)
>
>
>
>
>    
Hi Nicolae,

Using tools introduced in 0.5 to manage the M4 broker is probably not a 
good idea.  I believe qpid-route was present in the M4 release (in 
qpid/tags/M4/RC9/qpid/python/commands/qpid-route) so I'm not sure why 
you don't see it.

Did you branch a custom build because M4 didn't support your LDAP 
requirements?  Is there a reason that the cyrus-sasl libraries (used by 
the broker to handle authentication) don't meet your needs for LDAP?

In general, if you branch the project and make your own modifications, 
you either can't use new features and bug fixes introduced later in Qpid 
or you need to continually re-base your branch.

-Ted


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message