qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: SSL with C++ client returns "Unknown protocol: ssl"
Date Tue, 25 Aug 2009 15:13:47 GMT
Cullen Davis wrote:
> Gordon,
> 
> I do not have the qpidc package installed.  I set and exported QPID_NO_MODULE_DIR=true.
 (I also tried QPID_NO_MODULE_DIR=1)   I still get the "Unknown protocol: ssl (qpid/client/Connector.cpp:66)"
error.   

Does make check pass? In particular does the ssl_test run and does it fail?

> In an earlier post, you stated that the sslconnector.so plugin should be specified in
the QPID_LOAD_MODULE variable  "...or have the ssl client plugin in the standard location
for clients".   Can you elaborate on the standard location comment (in particular for a Fedora
10 installation)?    

The default is /usr/local/lib/qpid/client/ (though it can be changed at 
compile time). A make install should put the library there.

> I thought that perftest could be used to test my SSL implementation, but that code seems
to be out of the build.  Thank you for your assistance.

Yes, perftest can test ssl (with the --protocol option). When you say 
its out of the build you mean its not in the 0.5 distribution?

> 
> Cullen J. Davis
> CommIT Enterprises, Inc.
> 
> ________________________________________
> From: Gordon Sim [gsim@redhat.com]
> Sent: Tuesday, August 25, 2009 3:47 AM
> To: users@qpid.apache.org
> Subject: Re: SSL with C++ client returns "Unknown protocol: ssl"
> 
> Cullen Davis wrote:
>> I have not been able to get the SSL client connector to be loaded for the direct
examples.
>>
>> Per Gordon's instructions, I modified the  direct/declare_queues.cpp example to add
use a ConnectionSetting object when opening a Connection.  I set the ConnectionSetting.protocol
property to "ssl".
>>
>> 1) I start broker as detailed in step 1 of previous post.
>> 2) I set and export QPID_SSL_CERT_DB
>> 3) I set and export QPID_LOAD_MODULE (set ..../src/.libs/sslconnector.so - I used
a fully qualified path)
>> 4) I Execute the c++ example from the direct use cases:
>>     $ examples/declare_queues 127.0.0.1 5671 ssl
>>    The program errors with "Unknown protocol: ssl (qpid/client/Connector.cpp:66)"
>>
>> Obviously I am not getting the client to run with the SSL connector .  I thought
setting the QPID_LOAD_MODULE would make that happen.  Any thoughts as to why I am not getting
the sslconnector.so library to load?  I am running all tests on a straight install of Fedora
10 with the latest (807298) trunk code.
> 
> Do you have the qpidc rpm installed as well (rpm -qv qpidc)? If so
> perhaps exporting QPID_NO_MODULE_DIR=true might help(?).
> 
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
> 
> 
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
> 


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message