qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: SSL with C++ client returns "Unknown protocol: ssl"
Date Tue, 25 Aug 2009 07:47:38 GMT
Cullen Davis wrote:
> I have not been able to get the SSL client connector to be loaded for the direct examples.
 
> 
> Per Gordon's instructions, I modified the  direct/declare_queues.cpp example to add use
a ConnectionSetting object when opening a Connection.  I set the ConnectionSetting.protocol
property to "ssl".  
> 
> 1) I start broker as detailed in step 1 of previous post.
> 2) I set and export QPID_SSL_CERT_DB
> 3) I set and export QPID_LOAD_MODULE (set ..../src/.libs/sslconnector.so - I used a fully
qualified path)
> 4) I Execute the c++ example from the direct use cases: 
>     $ examples/declare_queues 127.0.0.1 5671 ssl
>    The program errors with "Unknown protocol: ssl (qpid/client/Connector.cpp:66)"
> 
> Obviously I am not getting the client to run with the SSL connector .  I thought setting
the QPID_LOAD_MODULE would make that happen.  Any thoughts as to why I am not getting the
sslconnector.so library to load?  I am running all tests on a straight install of Fedora 10
with the latest (807298) trunk code. 

Do you have the qpidc rpm installed as well (rpm -qv qpidc)? If so 
perhaps exporting QPID_NO_MODULE_DIR=true might help(?).

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message