qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Ritchie <ritch...@apache.org>
Subject Re: 0.5 and 3rd party persistence store
Date Tue, 07 Jul 2009 11:56:24 GMT
2009/7/6 Ted Ross <tross@redhat.com>:
> lroloson wrote:
>>
>> I am trying to build the 3rd party persistence store module. I have  used
>> SVN to get the 0.5 release from
>> https://svn.apache.org/repos/asf/qpid/branches/0.5-release/ , and I am able
>> to get that built on Linux (the broker and the  examples build without
>> error).  I got the 3rd party modules from
>> http://anonsvn.jboss.org.repos/rhmessaging/store/trunk/cpp  and configured
>> per the FAQ to use the qpid checkout. bootsrap and  configure of the 3rd
>> party seems to be completing without error. But  the make step is failing
>> here:
>> ...
>>         then mv -f ".deps/JournalImpl.Tpo" ".deps/JournalImpl.Plo";  else
>> rm -f ".deps/JournalImpl.Tpo"; exit 1; fi
>>  g++ -DHAVE_CONFIG_H -I. -I. -I.. -Werror -pedantic -Wall -Wextra -
>> Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -
>> Wvolatile-register-var -Winvalid-pch -Wno-system-headers -I/root/
>> Development/workspace/0.5-release/qpid/cpp/src -I/root/Development/
>> workspace/0.5-release/qpid/cpp/src/gen -I./gen -DRHM_CLEAN -pthread -g  -O2
>> -MT JournalImpl.lo -MD -MP -MF .deps/JournalImpl.Tpo -c  JournalImpl.cpp
>>  -fPIC -DPIC -o .libs/JournalImpl.o
>> JournalImpl.cpp:29:45: error: qpid/management/ManagementAgent.h: No  such
>> file or directory
>> ...
>> I do have the ManagementAgent.h file, but it is not in the path shown
>>  above, it is 0.5-release/qpid/cpp//src/qpid/agent/ManagementAgent.h. I
>>  believe I have revision 3466 of the 3rd party source.
>>
>> Any help would be appreciated ... thanks
>>
>> Larry Roloson
>>
>>
>
> Larry,
>
> The trunk of the store tracks the trunk of the Qpid SVN.  Since you are
> using qpid 0.5, you will need to use an older version of the store (there
> have been API changes to the plugin interface since 0.5).  Try using
> revision 3373 from the store SVN to build against qpid 0.5.

Would be good if there could be a matching branch for the cpp in the
jboss repository.
I see there is one there for the Java Broker persistent module.

Martin

> Alternatively, of course, you can build from the trunk for both the store
> and qpid if you wish.
>
> Regards,
>
> -Ted
>
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>
>



-- 
Martin Ritchie

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message