qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garrett Smith...@rrett.us.com>
Subject Authentication woes - C++ broker, Python client
Date Wed, 29 Apr 2009 02:43:19 GMT
I'm running into this error when I try to start a connection, which is
configured with what I believe to be a valid username and password:

 connection failed (320, u'connection-forced: Authentication failed')

I'm using the default guest/guest account. Here's what I'm seeing in the
broker log (trace enabled):

  info SASL: Starting authentication with mechanism: PLAIN
  info SASL: Authentication failed: SASL(-13): user not found: Password
  verification failed

I've verified that the guest account exists using "sasldblistusers2 -f 
/var/lib/qpidd/qpidd.sasldb". The output:

  guest@QPID: userPassword

I've tried this with new user accounts and different realms (specifying
--realm for qpidd as applicable). Same result.

There no indication in the trace log which SASL db is being used. The
contents of /etc/sasl2/qpidd.conf:

  mech_list: plain anonymous
  pwcheck_method: auxprop
  auxprop_plugin: sasldb
  sasldb_path: /var/lib/qpidd/qpidd.sasldb

If I comment out all of those lines, the output from qpidd (trace) is
exactly the same. So, I'm a bit confused as to how qpidd is getting its
information about SASL.

How can I explicitly tell qpidd where to find the SASL config?

Should the trace output contain details about which SASL confi it's
using? The only SASL related log output at startup is:

  info SASL enabled

That's a comforting fact, but then what? :)

Thanks for any help!

Garrett

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message