qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: A few clustering/failover questions
Date Tue, 10 Mar 2009 20:53:01 GMT
Sandy Pratt wrote:
> I was attempting to rejoin the broker to the cluster, and found some errors in the logs.
 This snippet below seems to be where it starts:
> 
> 2009-mar-09 10:53:47 trace 10.59.174.186:15159(DUMPEE) RECV 10.59.174.186:15159-0x8144690(local,catchup):
Frame[BEbe; channel=1; conte
> nt (21 bytes) 55khagadlc-8yrlp...]
> 2009-mar-09 10:53:47 debug Exception constructed: Unexpected command start frame. (qpid/SessionState.cpp:57)
> 2009-mar-09 10:53:47 error Connection exception: framing-error: Unexpected command start
frame. (qpid/SessionState.cpp:57)
> 2009-mar-09 10:53:47 error Connection 10.59.174.211:49354 closed by error: Unexpected
command start frame. (qpid/SessionState.cpp:57)(
> 501)
> 2009-mar-09 10:53:47 trace 10.59.174.186:15159(DUMPEE) RECV 10.59.174.186:15159-0x8144690(local,catchup):
Frame[BEbe; channel=1; {Clus
> terConnectionQueuePositionBody: queue=test.queue; position=19; }]
> 2009-mar-09 10:53:47 trace 10.59.174.186:15159(DUMPEE) RECV 10.59.174.186:15159-0x8144690(local,catchup):
Frame[Bbe; channel=1; {Messa
> geTransferBody: destination=\x00qpid-dump\x00; accept-mode=1; acquire-mode=0; }]
> 2009-mar-09 10:53:47 debug Exception constructed: Channel 1 is not attached (qpid/amqp_0_10/SessionHandler.cpp:67)
> 2009-mar-09 10:53:47 error Channel exception: not-attached: Channel 1 is not attached
(qpid/amqp_0_10/SessionHandler.cpp:67)
> 2009-mar-09 10:53:47 trace 10.59.174.186:15159(DUMPEE) RECV 10.59.174.186:15159-0x8144690(local,catchup):
Frame[be; channel=1; header
> (99 bytes); properties={{MessageProperties: content-length=0; message-id=86fe821e-9123-3ef0-bb79-3ded7e79c767;
content-type=text/plain
> ; user-id=guest; }{DeliveryProperties: redelivered=1; priority=4; delivery-mode=2; timestamp=1236621013709;
expiration=0; exchange=tes
> t.direct; routing-key=test.queue; }}]
> 2009-mar-09 10:53:47 debug Exception constructed: Channel 1 is not attached (qpid/amqp_0_10/SessionHandler.cpp:67)
> 
> 
> The unexpected command start frame seems to be where it started.  Before that I see a
bunch of RECV lines and afterwards a bunch of "Channel 1 is not attached" errors.
> 
> Any idea what this means?

This was a bug, it has been fixed on the trunk. It was a problem with 
replication to a new broker joining the cluster. Can you try a build from trunk? 
If you still see problems like this I'd like to know.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message