qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Trieloff <cctriel...@redhat.com>
Subject Re: M4 C++ build on Redhat 5
Date Tue, 03 Mar 2009 21:39:28 GMT

You should be able to build with the boost included in RHEL5, that is 
commonly done. Is you boost
installed in a standard location? or are are you unable to yum boost-devel?

Carl.



lroloson wrote:
> Steve 
>
>  
>
> I have not been able to find the boost-devel rpm, and the boost that yum
> finds seems to be pretty down level.  What is the best way to get boost
> installed with the headers?
>
>  
>
> Any help would be appreciated. Thanks 
>
>  
>
>  
>
> Larry Roloson
>
>
>
>  
>
> From: Steve Huston (via Nabble)
> [mailto:ml-user+168341-1583948052@n2.nabble.com] 
> Sent: Tuesday, March 03, 2009 4:31 PM
> To: lroloson
> Subject: RE: M4 C++ build on Redhat 5
>
>  
>
>   
>> I have read the INSTALL document contained in the 
>> qpid-cpp-m4.tar.gz file. I 
>> used yum to install ruby and boost, I have exported the path 
>> information per 
>> section 2.3. When I run configure I get the following error; 
>> ... 
>> ... 
>> ls: /src/qpidc-0.4/./../specs/amqp.0-10-qpid-errata.xml: No 
>> such file or directory 
>> checking for library containing dlopen... no 
>> checking for library containing clock_gettime... no 
>> checking for clock_gettime... no 
>> checking for clock_settime... no 
>> checking for valgrind... no 
>> checking for rpmlint... no 
>> checking for ruby... ruby 
>> checking boost/shared_ptr.hpp usability... no 
>> checking boost/shared_ptr.hpp presence... no 
>> checking for boost/shared_ptr.hpp... no 
>> configure: error: Missing required header files. 
>>
>> I am not trying to build from the trunk, I am not sure why it 
>> is looking for the specs? 
>>     
>
>
> It's just checking for the presence of the specs to see if the code 
> should be generated or not - the message is a bit confusing, but you 
> can ignore it. 
>
> It's choking because it can't find boost/shared_ptr.hpp as an 
> indication that the boost headers are available. 
>
>   
>> I have exported the CXXFLAGS, and the headers are 
>> there - but they are not being seen. 
>>     
>
> Did you install boost-devel in addition to boost? Boost-devel has the 
> header files the configure is looking for. 
>
> -Steve 
>
>
> --------------------------------------------------------------------- 
> Apache Qpid - AMQP Messaging Implementation 
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@...
> <http://n2.nabble.com/user/SendEmail.jtp?type=node&node=2418024&i=0>  
>
>
>
>
>   _____  
>
> This email is a reply to your post @
> http://n2.nabble.com/M4-C%2B%2B-build-on-Redhat-5-tp2417940p2418024.html
> You can reply by email or by visting the link above.
>
>  
>
>
>   


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message