qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Chase <adam.cha...@gmail.com>
Subject Re: batch accept issues?
Date Thu, 05 Mar 2009 14:56:09 GMT
I've attached a test that sometimes fails on my system.

It may not be the simplest example.

It tends to occur when the client is on a different machine than the
server.  (Not sure if it is timing related or not).

declare_queues.
producer puts 1000 messages split among 2 queues.
consumer subscribes to both and batches accepts to a third of the messages.
Once we've "accepted" 100 we actually do the accepts.

The consumer logs how many messages its accepted.
When I run qpid-tool, I occasionally don't see many message deletes at
all (much less than the consumer reports).

Any help is appreciated.

Thanks,

Adam


On Wed, Mar 4, 2009 at 4:26 AM, Gordon Sim <gsim@redhat.com> wrote:
> Adam Chase wrote:
>>
>> Have there been any issues fixed recently with regards to batch
>> accepting of messages?  I'm trying to accept messages 50 or so at a
>> time, and sometimes they just don't seem to be getting deleted.
>
> I assume this is with the c++ client? There is nothing I'm aware of. Do you
> have a simple test case that reproduces the issue?
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>
>

Mime
View raw message