qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Boyd <jdb...@etinternational.com>
Subject RE: Installing on RHEL4
Date Wed, 21 Jan 2009 17:20:42 GMT
On Wed, 2009-01-21 at 12:11 -0500, Steve Huston wrote:
> Hi Joshua,
> 
> > I'm trying to install QPID M4 (a recent RC) on RHEL4.
> 
> Ok.
> 
> > RHEL4 only has boost 1.32.  QPID obviously prefers a newer version
> of
> > boost, but there is the boost-1.32-support directory which 
> > I've applied, but I still can't get it to build.
> 
> Do you get past the configure?

No.  The last thing configure prints is the "configure: error:" line
shown below and no Makefile is generated.

> > I'm not trying anything fancy with the configure command.
> > 
> > Here is the end of the configure output:
> > checking for ruby... ruby
> > ls: 
> > /home/jdboyd/work/jmgr/build/msgLayer/qpid-M4//home/jdboyd/wor
> > k/jmgr/src/msgLayer/qpid-M4/cpp/../specs/amqp.0-10-qpid-errata
> > .xml: No such file or directory
> 
> Missing xml file is a problem... It looks as though the path it's
> looking in may be wrong. Are you cd'd to the qpid .../cpp directory?

OK, I was running the configure script from a separate install
directory.  The qpid source is
in /home/jdboyd/work/jmgr/src/msgLayer/qpid-M4/
while I would in /home/jdboyd/work/jmgr/build/msgLayer/qpid-M4/ typing
this command line:
/home/jdboyd/work/jmgr/src/msgLayer/qpid-M4/cpp/configure

If I switch to the cpp directory in the source and type: ./configure the
line complaining about the XML file goes away, but the complaint below
about "Boost libraries could not be found" persists.


> > checking boost/shared_ptr.hpp usability... yes
> > checking boost/shared_ptr.hpp presence... yes
> > checking for boost/shared_ptr.hpp... yes
> > checking uuid/uuid.h usability... yes
> > checking uuid/uuid.h presence... yes
> > checking for uuid/uuid.h... yes
> > checking for main in -lboost_filesystem... yes
> > checking for main in -lboost_program_options... yes
> > checking for main in -lboost_system... no
> > checking for main in -lboost_filesystem-d... no
> > checking for main in -lboost_program_options-d... no
> > checking for main in -lboost_system-d... no
> > configure: error: Boost libraries could not be found.
> > 
> > I've also attached the config.log file.
> > 
> > I've checked and I definitely don't have libboost_system-d or any
> > libboost_system libraries on the system, which seems to be 
> > something new to newer versions of boost.  
> > 
> > Is the boost-1.32-support stuff outdated and not going to be
> supported
> > any further?
> 
> I'm not sure of the official position on boost 1.32... Do you need
> this to work? Can you use boost 1.35?

It would simplify things greatly if it would work.


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message