qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Honton, Charles" <Charles_Hon...@intuit.com>
Subject RE: amqpexamples produce version mismatch: 0-9
Date Thu, 11 Dec 2008 15:13:21 GMT
I am running the Java Broker.  When will Java Broker support 0-10?  Is
there anything about these samples that require a 0-10 broker?  If not,
should an AQMP client downshift when it encounters a prior revision
broker?

Thanks,
chas
-----Original Message-----
From: Carl Trieloff [mailto:cctrieloff@redhat.com] 
Sent: Wednesday, December 10, 2008 5:56 PM
To: qpid-users@incubator.apache.org
Subject: Re: amqpexamples produce version mismatch: 0-9

Gordon Sim wrote:
> Honton, Charles wrote:
>> I'm experiencing a problem running any of the classes in
>> org.apache.qpid.example.amqpexample.  I always get a
>> ProtocolVersionMismatchException.  Is this expected with the current
>> codebase (December 10 trunk)?
>
> Are you running them against the java broker? If so that is expected 
> to fail. The java broker only support version 0-9, whereas those 
> examples are written to the 0-10 version of the specification.

To be specific, the issue should not be seen when running against the 
C++ broker.

Carl.


Mime
View raw message