qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olakara, Abdel" <Abdel.Olak...@Honeywell.com>
Subject RE: Example error and Java doc for Latest release
Date Fri, 31 Oct 2008 05:00:22 GMT

Hi Rajith,

There is no particular reason for using the low level APIs. I was just
trying out the example and getting a better understanding of Qpid. 

Regards,
Abdel Olakara


-----Original Message-----
From: Rajith Attapattu [mailto:rajith77@gmail.com] 
Sent: Friday, October 31, 2008 2:22 AM
To: qpid-users@incubator.apache.org
Cc: a.gazzarini@gmail.com
Subject: Re: Example error and Java doc for Latest release

Olakara,

For java we encourage people to use the JMS API as much as possible.
The underlying low level client could change btw versions.

Is there a specific reason why you don't want to use JMS?

Regards,

Rajith

On Wed, Oct 29, 2008 at 10:03 AM, Olakara, Abdel <
Abdel.Olakara@honeywell.com> wrote:
>
> Hi Andrea,
>
>  Thanks for your reply. I have downloaded
qpid-incubating-M3-java.tar.gz
> from the apache server. I got the example from this wiki site, what
> could be the issue?
>
> I think the old version of the class that you are talking about is the
> version of qpid right?
>
> Let me try refreshing the eclipse workspace!
>
> Thanks & Regards,
> Abdel Olakara
>
>
>
> -----Original Message-----
> From: Andrea Gazzarini [mailto:a.gazzarini@gmail.com]
> Sent: Wednesday, October 29, 2008 7:18 PM
> To: qpid-users@incubator.apache.org
> Subject: Re: Example error and Java doc for Latest release
>
> Maybe you have an old version of that class / project. Try to update
> your
> workspace...I just did it and I have a Connection class with an empty
> constructor...
>
> Regards,
> Andrea
>
> 2008/10/29 Olakara, Abdel <Abdel.Olakara@honeywell.com>
>
> > Hi all,
> >
> >
> >
> >  I am trying to start using Qpid. My server is running good :-)! I
am
> > trying to compile an example. The example has the following code:
> >
> >
> >
> > Connection con = new Connection();
> >
> > con.connect("localhost", 5672, "test", "guest", "guest",false);
> >
> >
> >
> > But, the IDE says Connection() constructor does not exist. And the
> code
> > assistant show only 2 argument parameterized constructor as:
> >
> >
> >
> > Connection(Sender<ProtocolEvent> a,ConnectionDelegate a1)
> >
> >
> >
> > I am not able to see a javadoc and the example do not run. Can
anybody
> > help me out with this? Can you please give the URL of latest
javadocs?
> >
> >
> >
> > Thanks in advance,
> >
> > Abdel Olakara
> >
> > http://technopaper.blogspot.com
> >
> >
> >
> >
> >
> >



--
Regards,

Rajith Attapattu
Red Hat
http://rajith.2rlabs.com/

Mime
View raw message