qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robbie Gemmell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DISPATCH-1149) authz plugin can no longer override conf file policy
Date Thu, 18 Oct 2018 21:58:00 GMT

     [ https://issues.apache.org/jira/browse/DISPATCH-1149?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robbie Gemmell updated DISPATCH-1149:
-------------------------------------
    Fix Version/s: 1.5.0

> authz plugin can no longer override conf file policy
> ----------------------------------------------------
>
>                 Key: DISPATCH-1149
>                 URL: https://issues.apache.org/jira/browse/DISPATCH-1149
>             Project: Qpid Dispatch
>          Issue Type: Bug
>            Reporter: Gordon Sim
>            Assignee: Gordon Sim
>            Priority: Major
>             Fix For: 1.5.0
>
>
> If enabled, the authz plugin should be allowed to defined the valid sources and targets
for a given connection and this should take precedence over anything in the policy file (which
may still be used for quotas).
> This was (I believe) an unintentional regression by https://github.com/apache/qpid-dispatch/commit/dc981ecc6cf31d8c605e84703a589553281281c2#diff-adc0a0fef2880417cb24cb072363fc29
which reverted the necessary change made in https://github.com/apache/qpid-dispatch/commit/eed8bb65497b23e512072f5ea9fefd8ed73921ef#diff-adc0a0fef2880417cb24cb072363fc29



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message