qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gemmellr <...@git.apache.org>
Subject [GitHub] qpid-proton issue #142: PROTON-1831: Incorrect open/close sequence for same ...
Date Fri, 27 Apr 2018 08:57:25 GMT
Github user gemmellr commented on the issue:

    https://github.com/apache/qpid-proton/pull/142
  
    The use of "invalid-field" for the error feels like it is maybe a little off. Its possible/likely
there is nothing wrong with the information in the fields of the attach, as none of it is
really actually checked (e.g whether its the same remote handle, itself a session:handle-in-use
error) other than someone got there previously with the name. Perhaps "illegal-state" might
be more applicable given the actual check being done?
    
    That said though, its not actually 100% clear it is an illegal state. The spec covers
attaching an active link a second time as resulting in the first attachment being detached
with the "stolen" link error. Its described for handling across different connections (something
proton thus cant actually do on its own) e.g during reconnect, but its not clear that precludes
it being the case on a single session or connection. However, it does seem far more likely
to be in result of an error for the situation to ever occur on a single session/connection
so perhaps treating it as such is the way to go in the end (plus any alternative would I guess
be much harder to achieve, so maybe its the only choice for now).


---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message