qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gordon Sim (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DISPATCH-927) detach not echoed back on multi-hop link route
Date Thu, 15 Feb 2018 21:39:00 GMT
Gordon Sim created DISPATCH-927:
-----------------------------------

             Summary: detach not echoed back on multi-hop link route
                 Key: DISPATCH-927
                 URL: https://issues.apache.org/jira/browse/DISPATCH-927
             Project: Qpid Dispatch
          Issue Type: Bug
            Reporter: Gordon Sim


In a two router network, router-a and router-b, a link route is defined in both directions
on both routers. There is also an associated connector to a broker on router-b. The address
is configured to be a topic on the broker.

If two receivers attach on this address to router-a, and then detach at the same time having
received the defined number of messages, frequently (but not always), one of the receivers
will not get a detach echoed back to it.

On inspection of protocol traces, it appears that router-b, though it gets the detach echoed
back from the broker, does not forward this back to the client (via router-a).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message