qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-5115) Windows client AMQP 1.0 support should be built in and not a loadable module
Date Fri, 04 Oct 2013 17:43:42 GMT

    [ https://issues.apache.org/jira/browse/QPID-5115?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13786396#comment-13786396
] 

ASF subversion and git services commented on QPID-5115:
-------------------------------------------------------

Commit 1529235 from chug@apache.org in branch 'qpid/trunk'
[ https://svn.apache.org/r1529235 ]

QPID-5115: AMQP 1.0 client support built in to qpidmessaging for all platforms
This commit disposes of the amqpc library and moves the functions into the
qpidmessaging library. Now any client that loads qpidmessaging gets amqp0-10
and amqp1.0 selectable through the connection protocol option. C++ brokers
still must load the amqp library to enable 1.0 support.

> Windows client AMQP 1.0 support should be built in and not a loadable module
> ----------------------------------------------------------------------------
>
>                 Key: QPID-5115
>                 URL: https://issues.apache.org/jira/browse/QPID-5115
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Client
>    Affects Versions: 0.24
>            Reporter: Chuck Rolke
>            Assignee: Chuck Rolke
>
> In order to get a Windows Qpid Messaging client support for AMQP 1.0 the user must define
an environment variable before executing the client program. In practice this is inconvenient
and it may well baffle new users simply trying to execute HelloWorld.
> For example, assume a native windows installation has proton.dll in P:\bin and the Qpid
messaging libraries in Q:\bin.
> If the user puts P:\bin and Q:\bin into his path and runs:
> {noformat}
> helloworld.exe
> {noformat}
> then no AMQP 1.0 support is available. Simply having qpidc.dll in the user path is not
enough. To get AMQP 1.0 the user must point to the amqpc.dll library:
> {noformat}
> set QPID_LOAD_MODULE=Q:\bin\qpidc.dll
> helloworld.exe
> {noformat}
> This problem is just as bad for .NET managed code where every application that wants
to inherit use of the client libraries must have this environment variable set.
> The solution proposed here is to simply build amqpc.dll into qpidmessaging.dll and have
support for AMQP 1.0 enabled automatically. AMPQ 1.0 support is enabled by loading the libraries
that are in the user's path.
> In order to use AMQP 1.0 users still must specify "{protocol:amqp1.0}" in the connection
options so 1.0 support is not enabled without them knowing about it.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message