qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Review Request 14361: QPID-5197: Remove obsolete --cluster-durable/persistLastNode options
Date Mon, 07 Oct 2013 14:09:47 GMT
On 10/07/2013 02:30 PM, Alan Conway wrote:
> My thinking was that since the feature is now gone on the broker, it is
> confusing to keep it in the tools.

I tend to agree, especially in this particular case.

> However you have a point about new
> tools against old brokers.
>
> Do you think we should keep the old features in the tools and put a
> deprecation in the release notes, then take them out next cycle?

This is another reason why I don't like the special handling for 
arguments to queues, exchanges etc. It unnecessarily couples the tool to 
a particular broker version. The more generic the tool is the better.

Note, that the modified qpid-config can still be used to request the 
feature against an older broker using the generic --argument option. 
That doesn't address Fraser's point of course, but if users had been 
using that option to begin with then this would not have been an issue.

Having the broker warn or fail on unrecognised options *is* important 
and as yet not completely done. (Need to have a way for plugins such as 
the store to register the options they recognise).

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message