qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: auto delete queue in cluster
Date Thu, 23 Sep 2010 15:42:03 GMT
On 09/22/2010 03:23 PM, Tim Chen wrote:
> Hi all,
>
> I've succesfully setup clustering in qpid.
>
> My problem now is that when my client creates a auto-delete queue in the cluster, everything
works correctly until I restart a broker in the cluster.
>
> The queue I created from the session will still be there, but it no longer will be set
auto-delete, which means when my client drops off the queue still remains in the cluster.
>
> I wonder if this is by design, or a bug in the qpid cluster?
>

This was a bug that was fixed back in May in revision 779183. What version of 
qpid are you using? 0.6 should have the fix. If there's been a regression I'll 
look into it.

Here's the commit log:

Author: Gordon Sim <gsim@apache.org>
Date:   Wed May 27 10:23:49 2009

     QPID-1488: Ensure policy state (+ store state & mgmt stats) are accurate on 
newly joined nodes by informing
                the queue of any logically enqueued messages that are currently 
acquired (but not accepted or
                released).

     QPID-1873: Ensure that the various properties of a queue (durability, 
exclusivity etc) are correctly replicated
                to new cluster members.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message