qpid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From acon...@apache.org
Subject [26/50] qpid-proton git commit: PROTON-209: Add a list of dependencies with tested minimum versions where they are known
Date Fri, 01 Sep 2017 15:03:54 GMT
PROTON-209: Add a list of dependencies with tested minimum versions where they are known


Project: http://git-wip-us.apache.org/repos/asf/qpid-proton/repo
Commit: http://git-wip-us.apache.org/repos/asf/qpid-proton/commit/8c3ba56b
Tree: http://git-wip-us.apache.org/repos/asf/qpid-proton/tree/8c3ba56b
Diff: http://git-wip-us.apache.org/repos/asf/qpid-proton/diff/8c3ba56b

Branch: refs/heads/go1
Commit: 8c3ba56b8e7dfe92fb23c409cb64e960dacae26a
Parents: 20da10d
Author: Justin Ross <jross@apache.org>
Authored: Thu Aug 17 16:38:39 2017 -0700
Committer: Justin Ross <jross@apache.org>
Committed: Thu Aug 17 16:38:39 2017 -0700

----------------------------------------------------------------------
 INSTALL.md | 25 +++++++++++++++++++++++--
 1 file changed, 23 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/qpid-proton/blob/8c3ba56b/INSTALL.md
----------------------------------------------------------------------
diff --git a/INSTALL.md b/INSTALL.md
index 83d1270..6a212c0 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -4,6 +4,27 @@ Installing Qpid Proton
 The CMake build system can build the entire codebase, including proton-c,
 and all its language bindings.
 
+Dependencies
+------------
+
+Cross-platform dependencies
+
+  - CMake 2.8.7+
+  - Swig 1.3+ (for the bindings)
+  - Python 2.6+ or 3 (for the Python binding)
+  - Ruby (for the Ruby binding)
+
+Linux dependencies
+
+  - GNU Make 3.81+
+  - GCC 4.4+
+  - Cyrus SASL 2.1+ (for SASL support)
+  - OpenSSL 1.0+ (for SSL support)
+
+Windows dependencies
+
+  - Visual Studio 2005 or newer (regular or C++ Express)
+
 CMake (Linux)
 -------------
 
@@ -26,7 +47,7 @@ language.
     $ yum install python-devel                               # Python
     $ yum install ruby-devel rubygem-rspec rubygem-simplecov # Ruby
     $ yum install rubygem-test-unit                          # Ruby on Fedora >= 25
-    $ yum install pphp-devel                                 # PHP
+    $ yum install php-devel                                  # PHP
     $ yum install perl-devel                                 # Perl
 
     # Dependencies needed for Python docs
@@ -89,7 +110,7 @@ The following packages must be installed:
 
 Additional packages are required for the language bindings:
 
-  - swig (www.swig.org)
+  - Swig (www.swig.org)
   - Development headers and libraries for the language of choice
 
 Notes:


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@qpid.apache.org
For additional commands, e-mail: commits-help@qpid.apache.org


Mime
View raw message