qpid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c...@apache.org
Subject svn commit: r1690816 - in /qpid/trunk/qpid/cpp: bindings/qpid/dotnet/CMakeLists.txt bindings/qpid/dotnet/configure-windows.ps1 bld-winsdk.ps1 src/CMakeLists.txt
Date Mon, 13 Jul 2015 20:49:49 GMT
Author: chug
Date: Mon Jul 13 20:49:48 2015
New Revision: 1690816

URL: http://svn.apache.org/r1690816
Log:
QPID-6641: Update Windows SDK build for VS2013, Boost 1.58
Relax requirement for boost/include dir. Boost.org upstream builds don't
have them.

Modified:
    qpid/trunk/qpid/cpp/bindings/qpid/dotnet/CMakeLists.txt
    qpid/trunk/qpid/cpp/bindings/qpid/dotnet/configure-windows.ps1
    qpid/trunk/qpid/cpp/bld-winsdk.ps1
    qpid/trunk/qpid/cpp/src/CMakeLists.txt

Modified: qpid/trunk/qpid/cpp/bindings/qpid/dotnet/CMakeLists.txt
URL: http://svn.apache.org/viewvc/qpid/trunk/qpid/cpp/bindings/qpid/dotnet/CMakeLists.txt?rev=1690816&r1=1690815&r2=1690816&view=diff
==============================================================================
--- qpid/trunk/qpid/cpp/bindings/qpid/dotnet/CMakeLists.txt (original)
+++ qpid/trunk/qpid/cpp/bindings/qpid/dotnet/CMakeLists.txt Mon Jul 13 20:49:48 2015
@@ -184,6 +184,15 @@ if (MSVC)
         set(DOTNET_TARGET_FRAMEWORK_VERSION "v4.5")
         set(DOTNET_PLATFORM_TOOLSET         "<PlatformToolset>v110</PlatformToolset>")
 
+    elseif(${CMAKE_GENERATOR} MATCHES "^Visual Studio 12")
+        # Visual Studio 2013
+        select_msvcx_files()
+        set(DOTNET_MSVC_SELECT              "msvcx")
+        set(DOTNET_SLN_FILE_FORMAT          "13.00")
+        set(DOTNET_SLN_VISUAL_STUDIO        "Visual Studio 2013")
+        set(DOTNET_TARGET_FRAMEWORK_VERSION "v4.5")
+        set(DOTNET_PLATFORM_TOOLSET         "<PlatformToolset>v120</PlatformToolset>")
+
     else()
         message(FATAL_ERROR "No DOTNET binding support available for ${CMAKE_GENERATOR}")
     endif()

Modified: qpid/trunk/qpid/cpp/bindings/qpid/dotnet/configure-windows.ps1
URL: http://svn.apache.org/viewvc/qpid/trunk/qpid/cpp/bindings/qpid/dotnet/configure-windows.ps1?rev=1690816&r1=1690815&r2=1690816&view=diff
==============================================================================
--- qpid/trunk/qpid/cpp/bindings/qpid/dotnet/configure-windows.ps1 (original)
+++ qpid/trunk/qpid/cpp/bindings/qpid/dotnet/configure-windows.ps1 Mon Jul 13 20:49:48 2015
@@ -115,6 +115,8 @@ $global:txtWH   = 'Write-Host'
 # Visual Studio version selection dialog items and choice
 #
 [array]$global:VsVersionCmakeChoiceList = `
+    "Visual Studio 2013 - x86", `
+    "Visual Studio 2013 - x64", `
     "Visual Studio 2012 - x86", `
     "Visual Studio 2012 - x64", `
     "Visual Studio 2010 - x86", `
@@ -188,7 +190,7 @@ function SanityCheckBoostPath ($path=0)
     if ($path -ne $null) {
         $displayPath = $path
 
-        $toTest = ('include', 'lib')
+        $toTest = ('lib')
         foreach ($pattern in $toTest) {
             $target = Join-Path $path $pattern
             if (!(Test-Path -path $target)) {
@@ -418,7 +420,15 @@ function ParseStudioSelection
         [string] $vsSelection
     )
     Write-Host "Checking studio version: $vsSelection"
-    if ($vsSelection.Contains("2012")) {
+    if ($vsSelection.Contains("2013")) {
+        $global:vsVersion = "Visual Studio 2013"
+        $global:cmakeGenerator = "Visual Studio 12 2013"
+        $global:vsSubdir = "msvc12"
+        $global:vsSubdirX = "msvcx"
+        $global:cmakeCompiler = "-vc120"
+        $global:vsShortName = "2013"
+        $global:vsEnvironment = """%VS120COMNTOOLS%..\..\VC\vcvarsall.bat"""
+    } elseif ($vsSelection.Contains("2012")) {
         $global:vsVersion = "Visual Studio 2012"
         $global:cmakeGenerator = "Visual Studio 11"
         $global:vsSubdir = "msvc11"
@@ -443,7 +453,7 @@ function ParseStudioSelection
         $global:vsShortName = "2008"
         $global:vsEnvironment = """%VS90COMNTOOLS%..\..\VC\vcvarsall.bat"""
     } else {
-        Write-Host "Visual Studio must be 2008, 2010, or 2012"
+        Write-Host "Visual Studio must be 2008, 2010, 2012, or 2013"
         exit
     }
     $global:vsSelectedOption = $vsSelection

Modified: qpid/trunk/qpid/cpp/bld-winsdk.ps1
URL: http://svn.apache.org/viewvc/qpid/trunk/qpid/cpp/bld-winsdk.ps1?rev=1690816&r1=1690815&r2=1690816&view=diff
==============================================================================
--- qpid/trunk/qpid/cpp/bld-winsdk.ps1 (original)
+++ qpid/trunk/qpid/cpp/bld-winsdk.ps1 Mon Jul 13 20:49:48 2015
@@ -173,8 +173,13 @@ function BuildAPlatform
                 $msvcVer = "msvc11"
                 $msvcVerX = "msvcx"
             } else {
-                Write-Host "illegal vsName parameter: $vsName Choose VS2008, VS2010, or VS2012"
-                exit
+                if ($vsName -eq "VS2013") {
+                    $msvcVer = "msvc12"
+                    $msvcVerX = "msvcx"
+                } else {
+                    Write-Host "illegal vsName parameter: $vsName Choose VS2008, VS2010,
VS2012, or VS2013"
+                    exit
+                }
             }
         }
     }
@@ -413,8 +418,12 @@ if ( !($global:vsVersion -eq $null) ) {
             if ($global:vsVersion -eq "VS2012") {
                 $generator = "Visual Studio 11"
             } else {
-                Write-Host "Visual Studio Version must be VS2008, VS2010, or VS2012"
-                exit
+                if ($global:vsVersion -eq "VS2013") {
+                    $generator = "Visual Studio 12"
+                } else {
+                    Write-Host "Visual Studio Version must be VS2008, VS2010, VS2012, or
VS2013"
+                    exit
+                }
             }
         }
     }

Modified: qpid/trunk/qpid/cpp/src/CMakeLists.txt
URL: http://svn.apache.org/viewvc/qpid/trunk/qpid/cpp/src/CMakeLists.txt?rev=1690816&r1=1690815&r2=1690816&view=diff
==============================================================================
--- qpid/trunk/qpid/cpp/src/CMakeLists.txt (original)
+++ qpid/trunk/qpid/cpp/src/CMakeLists.txt Mon Jul 13 20:49:48 2015
@@ -179,7 +179,8 @@ if (NOT DEFINED Boost_ADDITIONAL_VERSION
         "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0"
         "1.48" "1.48.0" "1.49" "1.49.0" "1.50" "1.50.0"
         "1.51" "1.51.0" "1.52" "1.52.0" "1.53" "1.53.0"
-        "1.54" "1.54.0" "1.55" "1.55.0")
+        "1.54" "1.54.0" "1.55" "1.55.0" "1.56" "1.56.0"
+        "1.57" "1.57.0" "1.58" "1.58.0")
 endif (NOT DEFINED Boost_ADDITIONAL_VERSIONS)
 
 # Discover Boost version



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@qpid.apache.org
For additional commands, e-mail: commits-help@qpid.apache.org


Mime
View raw message