qpid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c...@apache.org
Subject svn commit: r1199507 - /qpid/trunk/qpid/cpp/src/CMakeLists.txt
Date Tue, 08 Nov 2011 22:49:34 GMT
Author: chug
Date: Tue Nov  8 22:49:34 2011
New Revision: 1199507

URL: http://svn.apache.org/viewvc?rev=1199507&view=rev
Log:
QPID-2640 Visual Studio 2010

Add new pdb-name munging logic for 2010.
Add Boost_ADDITIONAL_VERSION setting to aid windows-based cmake.

Modified:
    qpid/trunk/qpid/cpp/src/CMakeLists.txt

Modified: qpid/trunk/qpid/cpp/src/CMakeLists.txt
URL: http://svn.apache.org/viewvc/qpid/trunk/qpid/cpp/src/CMakeLists.txt?rev=1199507&r1=1199506&r2=1199507&view=diff
==============================================================================
--- qpid/trunk/qpid/cpp/src/CMakeLists.txt (original)
+++ qpid/trunk/qpid/cpp/src/CMakeLists.txt Tue Nov  8 22:49:34 2011
@@ -46,7 +46,8 @@ MACRO (install_pdb theLibrary theCompone
     if (MSVC)
         get_target_property(library_dll ${theLibrary} LOCATION)
         string(REPLACE .dll .pdb library_pdb ${library_dll})
-        string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
+        string(REPLACE $(OutDir)        \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
+        string(REPLACE $(Configuration) \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
         string(REPLACE .pdb d.pdb libraryd_pdb ${library_pdb})
         #message(STATUS "_pdb: ${library_pdb}, ${libraryd_pdb}")
         install (PROGRAMS
@@ -290,6 +291,14 @@ else (CMAKE_SYSTEM_NAME STREQUAL Windows
   set (Boost_components filesystem program_options unit_test_framework)
 endif (CMAKE_SYSTEM_NAME STREQUAL Windows)
 
+# Visual Studio 2010 requires boost 1.45 or better.
+# The choice here is to fail demanding the user to update CMake to version N
+# where Boost 1.45 is supported, or we can just accept some versions using
+# the Additional_versions variable.
+if (NOT DEFINED Boost_ADDITIONAL_VERSIONS)
+  set (Boost_ADDITIONAL_VERSIONS "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0")
+endif (NOT DEFINED Boost_ADDITIONAL_VERSIONS)
+
 find_package(Boost 1.33 REQUIRED COMPONENTS ${Boost_components})
 if(NOT Boost_FOUND)
   message(FATAL_ERROR "Boost C++ libraries not found.  Please install or try setting BOOST_ROOT")



---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:commits-subscribe@qpid.apache.org


Mime
View raw message