qpid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cctriel...@apache.org
Subject svn commit: r573059 - in /incubator/qpid/trunk/qpid/cpp: README configure.ac
Date Wed, 05 Sep 2007 21:11:50 GMT
Author: cctrieloff
Date: Wed Sep  5 14:11:50 2007
New Revision: 573059

URL: http://svn.apache.org/viewvc?rev=573059&view=rev
Log:
applied Nuno's patch

Modified:
    incubator/qpid/trunk/qpid/cpp/README
    incubator/qpid/trunk/qpid/cpp/configure.ac

Modified: incubator/qpid/trunk/qpid/cpp/README
URL: http://svn.apache.org/viewvc/incubator/qpid/trunk/qpid/cpp/README?rev=573059&r1=573058&r2=573059&view=diff
==============================================================================
--- incubator/qpid/trunk/qpid/cpp/README (original)
+++ incubator/qpid/trunk/qpid/cpp/README Wed Sep  5 14:11:50 2007
@@ -60,7 +60,7 @@
 
 On linux most packages can be installed using your distribution's package
 management tool. For example on Fedora:
-  # yum install pkgconfig e2fsprogs boost-devel cppunit-devel openais
+  # yum install pkgconfig e2fsprogs boost-devel cppunit-devel openais ruby
   # yum install make gcc-c++ autoconf automake libtool doxygen help2man graphviz
 
 Follow the manual installation instruction below for any packages not

Modified: incubator/qpid/trunk/qpid/cpp/configure.ac
URL: http://svn.apache.org/viewvc/incubator/qpid/trunk/qpid/cpp/configure.ac?rev=573059&r1=573058&r2=573059&view=diff
==============================================================================
--- incubator/qpid/trunk/qpid/cpp/configure.ac (original)
+++ incubator/qpid/trunk/qpid/cpp/configure.ac Wed Sep  5 14:11:50 2007
@@ -117,6 +117,7 @@
 
 AC_CHECK_PROG([RUBY], [ruby], [ruby])
 test -n "$RUBY" && generate=yes
+test -z "$RUBY" && AC_MSG_ERROR([Missing ruby installation (try "yum install ruby").])
 
 specdir=`pwd`/$srcdir/../specs  
 AMQP_XML=$specdir/amqp-transitional.0-10.xml
@@ -134,6 +135,9 @@
 # Check for headers from required devel kits.
 AC_CHECK_HEADERS([boost/shared_ptr.hpp uuid/uuid.h],,
   AC_MSG_ERROR([Missing required header files.]))
+
+LDFLAGS="$LDFLAGS -lprofiler"
+
 
 # Check for cluster requirements. Need openais 0.80.3 or higher.x1
 save_ldflags=$LDFLAGS  



Mime
View raw message