pulsar-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] drdrill opened a new issue #3068: Maven Build Error 2.2.0
Date Tue, 27 Nov 2018 14:49:34 GMT
drdrill opened a new issue #3068: Maven Build Error 2.2.0
URL: https://github.com/apache/pulsar/issues/3068
 
 
   #### Expected behavior
   
   Maven build should work correctly, always, both in Linux and in Windows
   
   #### Actual behavior
   
   In Linux, maven build encounters error when it tries to access non-existing URL:  https://yahoo.bintray.com/maven/org/apache/apache/18/apache-18.pom
   
   [DEBUG] Using transporter WagonTransporter with priority -1.0 for https://yahoo.bintray.com/maven
   [DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://yahoo.bintray.com/maven
via proxy.company.com:80 with username=user, password=***
   Downloading: https://yahoo.bintray.com/maven/org/apache/apache/18/apache-18.pom
   [DEBUG] Writing tracking file /home/user/.m2/repository/org/apache/apache/18/apache-18.pom.lastUpdated
   [ERROR] [ERROR] Some problems were encountered while processing the POMs:
   [FATAL] Non-resolvable parent POM for org.apache.pulsar:pulsar:2.2.0: Could not transfer
artifact org.apache:apache:pom:18 from/to central (https://repo1.maven.org/maven2): Not authorized
by proxy , ReasonPhrase: Proxy Authentication Required. and 'parent.relativePath' points at
wrong local POM @ line 27, column 11
    @
   [ERROR] The build could not read 1 project -> [Help 1]
   org.apache.maven.project.ProjectBuildingException: Some problems were encountered while
processing the POMs:
   [FATAL] Non-resolvable parent POM for org.apache.pulsar:pulsar:2.2.0: Could not transfer
artifact org.apache:apache:pom:18 from/to central (https://repo1.maven.org/maven2): Not authorized
by proxy , ReasonPhrase: Proxy Authentication Required. and 'parent.relativePath' points at
wrong local POM @ line 27, column 11
   
   #### Steps to reproduce
   
   On a clean system, download Pulsar 2.2.0 source, install Java and Maven, and execute the
Maven Build
   
   #### System configuration
   **Pulsar version**: 2.2.0
   Oracle Linux Server release 6.10
   Java(TM) SE Runtime Environment (build 1.8.0_181-b13)
   Apache Maven 3.3.3
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message