provisionr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul Sharma <rahul0...@gmail.com>
Subject Re: Jenkins build is still unstable: provisionr-master #43
Date Tue, 09 Jul 2013 03:31:25 GMT
Apologies for sending incomplete mail  ! Now the complete issue looks like
this :

The failing build is due to the non-standard maven repository. The build is
made on a ubuntu-slave which has its own local repository at a custom
location. This setting is passed in the build eg  in d build 45 the local
repos was set as :
       -Dmaven.repo.local=/home/jenkins/jenkins-slave/maven-repositories/1

Now we need to pass this setting to pax exam which is responsible for
determining maven artifact. The way to do this is to pass this
*maven.repo.local* variable to *org.ops4j.pax.url.mvn.localRepository*.
This should be done in the profile that builds on jenkins.

Karaf has the similar situation the have a test case [1] which looks for
artifact using pax. Thus they build a profile in their pom.xml [2] which
can pick the local repo location and set the required varibale. Also it is
easy to reproduce on local just enable the <localRepositry> tag in
maven/conf/settings.xml. Since this is something related to our pm
configuration I will open a JIRA for the same.


regards,
Rahul

[1]
https://svn.apache.org/repos/asf/karaf/trunk/itests/src/test/java/org/apache/karaf/itests/KarafTestSupport.java
[2]https://svn.apache.org/repos/asf/karaf/trunk/itests/pom.xml





On Tue, Jul 9, 2013 at 8:51 AM, Rahul Sharma <rahul0208@gmail.com> wrote:

> The failing build is due to the non-standard maven repository. The build
> is made on a ubuntu-slave which has its own local repostry at a custom
> location. This setting is paassed in the build eg  in d build 45 the local
> repos was set as
> -Dmaven.repo.local=/home/jenkins/jenkins-slave/maven-repositories/1
>
>
> On Sun, Jul 7, 2013 at 3:13 PM, Andrei Savu <savu.andrei@gmail.com> wrote:
>
>> No idea why this is happening. Maybe due to file size?
>>
>> I think we need to report this on builds@apache.org or on INFRA JIRA.
>>
>> -- Andrei Savu
>>
>> On Sat, Jul 6, 2013 at 5:48 PM, Rahul Sharma <rahul0208@gmail.com> wrote:
>>
>> > The build has just one test failure.It is not able to find the artifact
>> > being referred in one of the tests. The artifact gets built but it is
>> > install on one of the slaves and for some reason the test is trying to
>> find
>> > it on master, which is giving the error. Any ideas on how to fix this ?
>> >
>> > regards
>> > Rahul
>> >
>> >
>> > On Sat, Jul 6, 2013 at 6:39 AM, Apache Jenkins Server <
>> > jenkins@builds.apache.org> wrote:
>> >
>> > > See <https://builds.apache.org/job/provisionr-master/43/>
>> > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message