predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pat Ferrel <...@occamsmachete.com>
Subject Upgrading to PredictionIO 0.12.0
Date Wed, 18 Oct 2017 17:45:27 GMT
PIO-0.12.0 by default, compiles and runs expecting ES5. If you are upgrading (not installing
from clean) you will have an issue because ES1 indexes are not upgradable in any simple way.
The simplest way to upgrade to pio-0.12.0 and ES5 is to do `pio export` to backup BEFORE upgrading—so
export with PIO-0.11.0. Then do a full clean upgrade wiping all data and `pio import` the
data back into the app names you were using. This should restore indexes in ES5 and data in
HBase or Postgres.This will change the keys you were using with PIO-0.11.0 unless you explicitly
set them back to the same values in `pio app new…`. You will also need to train to get models
re-created.

Upgrading is far more complicated with this release so think through what you are doing and
be sure to backup your data.

Again these issues to not impact clean installs. 
Mime
View raw message