predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yevgeny Khodorkovsky <y.khodorkov...@gmail.com>
Subject Re: sbt.ResolveException: unresolved dependency: org.apache.predictionio#pio-build;0.11.0-incubrating
Date Tue, 22 Aug 2017 16:44:03 GMT
...incubRating... :)

On Tue, Aug 22, 2017 at 09:40 Pat Ferrel <pat@occamsmachete.com> wrote:

> Oh, I see which template now. You shouldn’t build PIO differently. You
> only need to change the template to match PIO.
> Remove project/pio-build.sbt. Then replace these  line in the template’s
> build.sbt:
>
>
> organization := “org.preditionio"
>
> libraryDependencies ++= Seq(
>   "io.prediction"    %% "core"          % pioVersion.value % "provided",
>
> with these and notice the different pioVersion, not pioVersion.value !
>
> val pioVersion = "0.11.0-incubating"
>
> libraryDependencies ++= Seq(
>   "org.apache.predictionio" %% "apache-predictionio-core" % pioVersion
> % "provided",
>
>
> When you are done and it works, consider submitting a PR to the original
> repo.
>
>
>
> On Aug 22, 2017, at 9:22 AM, Pat Ferrel <pat@occamsmachete.com> wrote:
>
> One error is the version of PIO in your templates build.sbt does not match
> the one you have installed.
>
> But not all templates work with the stack you have installed either.
> Templates are like a separate app from PIO, in the sense that they have
> their own dependencies and their own build.sbt. The way you build and
> install PIO must match what your template needs or vice versa.
>
> What template are you building.
>
>
> On Aug 22, 2017, at 3:52 AM, abhimanyunagrath@gmail.com <
> abhimanyu.nagrath@tracxn.com> wrote:
>
> Hi I am new to predictionio( v 0.11.0-incubrationg with spark- 2.1.0
>  elasticsearch- 5.2.1 hbase - 1.2.6)and I am using template
> https://github.com/alexice/template-scala-parallel-svd-item-similarity .
> This template is compaitable with min 0.9.2 version of predictionio and
> require apache pio conversion . So I replaced io.prediction with
> org.apache.predictionio and changed the version to 0.11.0-incubrating in
> files(build.sbt,template.json,project/assembly.sbt
> <https://github.com/alexice/template-scala-parallel-svd-item-similarity/blob/master/project/assembly.sbt>
> ,project/pio-build.sbt) after that in my template folder I just ran pio
> build --verbose and git the following error :
>
> [INFO] [Engine$] [warn] ::::::::::::::::::::::::::::::::::::::::::::::
> [INFO] [Engine$] [warn] ::          UNRESOLVED DEPENDENCIES         ::
> [INFO] [Engine$] [warn] ::::::::::::::::::::::::::::::::::::::::::::::
> [INFO] [Engine$] [warn] ::
> org.apache.predictionio#pio-build;0.10.0-incubrating: not found
> [INFO] [Engine$] [warn] ::::::::::::::::::::::::::::::::::::::::::::::
> [INFO] [Engine$] [warn]
> [INFO] [Engine$] [warn] Note: Some unresolved dependencies have extra
> attributes.  Check that these dependencies exist with the requested
> attributes.
> [INFO] [Engine$] [warn] org.apache.predictionio:pio-build:0.11.0-incubrating
> (scalaVersion=2.10, sbtVersion=0.13)
> [INFO] [Engine$] [warn]
> [INFO] [Engine$] [warn] Note: Unresolved dependencies path:
> [INFO] [Engine$] [warn] org.apache.predictionio:pio-build:0.11.0-incubrating
> (scalaVersion=2.10, sbtVersion=0.13)
> (/predictionio/apache-predictionio-0.11.0-incubating/template-scala-parallel-svd-item-similarity/project/pio-build.sbt#L1-2)
> [INFO] [Engine$] [warn]  +-
> default:template-scala-parallel-svd-item-similarity-build:0.1-SNAPSHOT
> (scalaVersion=2.10, sbtVersion=0.13)
> [INFO] [Engine$] sbt.ResolveException: unresolved dependency:
> org.apache.predictionio#pio-build;0.11.0-incubrating: not found
> [INFO] [Engine$] at
> sbt.IvyActions$.sbt$IvyActions$$resolve(IvyActions.scala:313)
> [INFO] [Engine$] at
> sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:191)
> [INFO] [Engine$] at
> sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:168)
> [INFO] [Engine$] at
> sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:156)
> [INFO] [Engine$] at
> sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:156)
> [INFO] [Engine$] at sbt.IvySbt$$anonfun$withIvy$1.apply(Ivy.scala:133)
> [INFO] [Engine$] at sbt.IvySbt.sbt$IvySbt$$action$1(Ivy.scala:57)
> [INFO] [Engine$] at sbt.IvySbt$$anon$4.call(Ivy.scala:65)
> [INFO] [Engine$] at
> xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:93)
> [INFO] [Engine$] at
> xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:78)
> [INFO] [Engine$] at
> xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:97)
> [INFO] [Engine$] at xsbt.boot.Using$.withResource(Using.scala:10)
> [INFO] [Engine$] at xsbt.boot.Using$.apply(Using.scala:9)
> [INFO] [Engine$] at
> xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:58)
> [INFO] [Engine$] at xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:48)
> [INFO] [Engine$] at xsbt.boot.Locks$.apply0(Locks.scala:31)
> [INFO] [Engine$] at xsbt.boot.Locks$.apply(Locks.scala:28)
> [INFO] [Engine$] at sbt.IvySbt.withDefaultLogger(Ivy.scala:65)
> [INFO] [Engine$] at sbt.IvySbt.withIvy(Ivy.scala:128)
> [INFO] [Engine$] at sbt.IvySbt.withIvy(Ivy.scala:125)
> [INFO] [Engine$] at sbt.IvySbt$Module.withModule(Ivy.scala:156)
> [INFO] [Engine$] at sbt.IvyActions$.updateEither(IvyActions.scala:168)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1481)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1477)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$121.apply(Defaults.scala:1512)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$121.apply(Defaults.scala:1510)
> [INFO] [Engine$] at
> sbt.Tracked$$anonfun$lastOutput$1.apply(Tracked.scala:37)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1515)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1509)
> [INFO] [Engine$] at
> sbt.Tracked$$anonfun$inputChanged$1.apply(Tracked.scala:60)
> [INFO] [Engine$] at sbt.Classpaths$.cachedUpdate(Defaults.scala:1532)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1459)
> [INFO] [Engine$] at
> sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1411)
> [INFO] [Engine$] at
> scala.Function1$$anonfun$compose$1.apply(Function1.scala:47)
> [INFO] [Engine$] at
> sbt.$tilde$greater$$anonfun$$u2219$1.apply(TypeFunctions.scala:40)
> [INFO] [Engine$] at sbt.std.Transform$$anon$4.work(System.scala:63)
> [INFO] [Engine$] at
> sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:228)
> [INFO] [Engine$] at
> sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:228)
> [INFO] [Engine$] at sbt.ErrorHandling$.wideConvert(ErrorHandling.scala:17)
> [INFO] [Engine$] at sbt.Execute.work(Execute.scala:237)
> [INFO] [Engine$] at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:228)
> [INFO] [Engine$] at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:228)
> [INFO] [Engine$] at
> sbt.ConcurrentRestrictions$$anon$4$$anonfun$1.apply(ConcurrentRestrictions.scala:159)
> [INFO] [Engine$] at
> sbt.CompletionService$$anon$2.call(CompletionService.scala:28)
> [INFO] [Engine$] at
> java.util.concurrent.FutureTask.run(FutureTask.java:266)
> [INFO] [Engine$] at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> [INFO] [Engine$] at
> java.util.concurrent.FutureTask.run(FutureTask.java:266)
> [INFO] [Engine$] at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
> [INFO] [Engine$] at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
> [INFO] [Engine$] at java.lang.Thread.run(Thread.java:748)
> [INFO] [Engine$] [error] (*:update) sbt.ResolveException: unresolved
> dependency: org.apache.predictionio#pio-build;0.11.0-incubrating: not found
> [INFO] [Engine$] Project loading failed: (r)etry, (q)uit, (l)ast, or
> (i)gnore?
> [ERROR] [Engine$] Return code of build command:
> /predictionio/apache-predictionio-0.11.0-incubating/PredictionIO-0.11.0-incubating/sbt/sbt
>  package assemblyPackageDependency is 1. Aborting.
> [INFO] [Engine$] Looking for an engine...
> [ERROR] [Engine$] No engine found. Your build might have failed. Aborting.
>
>
> I googled it out and was not able to find any solution. Any help is
> appreciated.
>
> This email is subject to Tracxn's Email Policy
> <https://tracxn.com/emailpolicy>
>
> --
> You received this message because you are subscribed to the Google Groups
> "actionml-user" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to actionml-user+unsubscribe@googlegroups.com.
> To post to this group, send email to actionml-user@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/actionml-user/4825593b-215f-43ef-a6cf-cda0a5abb57b%40googlegroups.com
> <https://groups.google.com/d/msgid/actionml-user/4825593b-215f-43ef-a6cf-cda0a5abb57b%40googlegroups.com?utm_medium=email&utm_source=footer>
> .
> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "actionml-user" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to actionml-user+unsubscribe@googlegroups.com.
> To post to this group, send email to actionml-user@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/actionml-user/C9757239-6A16-4617-BD8E-64650EBD247E%40occamsmachete.com
> <https://groups.google.com/d/msgid/actionml-user/C9757239-6A16-4617-BD8E-64650EBD247E%40occamsmachete.com?utm_medium=email&utm_source=footer>
> .
> For more options, visit https://groups.google.com/d/optout.
>
>

Mime
View raw message