predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pat Ferrel <...@occamsmachete.com>
Subject Re: Recommendation not taking new data
Date Sun, 30 Jul 2017 18:52:20 GMT
Could be several things. Did you delete data and re-run the integration test? If you did this
it will wipe your data and re-create handmade data. It’s supposed to be an example and test.
It’s an example that must be modified to be useful for your data.

To be safe create a new app with new data, appName, and eventNames, then create your own engine.json
from engine.json.template to reflect how you name events, and go from there, The import script
is also an example, not meant to work on any type of data so you may need to modify it to
fit yours or use an SDK to send data to your app via its access key.

BTW: There are lots of answers in the archives of the Google Group for the UR, in the CC above

On Jul 30, 2017, at 10:59 AM, Saarthak Chandra <chandra.saarthak@gmail.com> wrote:

Hi,

I am working with the Universal recommender.
I ran the integration test and it runs fine.
Then I wanted to add my own data, so I ran a script to post my data to the recommender, after
doing a "pio app data-delete handmade".

However, even after pio build,train and deploy, I get recommendations on the older data.

Any thing I missed out ??

-- 
Saarthak Chandra ,
Masters in Computer Science,
Cornell University.


Mime
View raw message