predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ravi Kiran <ravi.gun...@gmail.com>
Subject Re: Invalid app name INVALID_APP_NAME
Date Wed, 19 Apr 2017 03:20:32 GMT
[INFO] [App$]                 Name |   ID |
                      Access Key | Allowed Event(s)
[INFO] [App$]                app10 |   10 |
                         mnbvcxz | (all)
[INFO] [App$]         sample_app10 |   11 |
                            1234 | (all)
[INFO] [App$]         sample_app21 |   13 |
                            4321 | (all)
[INFO] [App$]         sample_app22 |   14 |
                        4321abcd | (all)
[INFO] [App$]         sample_app23 |   15 |
                       4321abcde | (all)
[INFO] [App$]         sample_app26 |   18 |
                     4321abcdefg | (all)
[INFO] [App$]              wineapp |   19 |
                     wineappeine | (all)
[INFO] [App$] Finished listing 19 app(s).


This is output of pio app list

On Wed, Apr 19, 2017 at 8:42 AM, Ravi Kiran <ravi.gunale@gmail.com> wrote:

> *Contents of engine.json*
>
> {
>   "id": "default",
>   "description": "Default settings",
>   "engineFactory": "mlframework.ClassificationEngine",
>   "datasource": {
>     "params": {
>       "appName": "wineapp"
>     }
>   },
>   "algorithms": [
>     {
>       "name": "naive",
>       "params": {
>         "lambda": 1.0
>       }
>     }
>   ]
> }
>
>
> *Location of engine.json*
> /home/user_name/Documents/code/apache-predictionio-0.10.
> 0-incubating/PredictionIO-0.10.0-incubating/sample_classifier/engine.json
> I have installed template in sample_classifier folder
>
>
>
>
> On Wed, Apr 19, 2017 at 8:32 AM, Vaghawan Ojha <vaghawan781@gmail.com>
> wrote:
>
>> What does your pio app list produce?
>>
>> And can you also send a screenshot of your engine.json. This engine.json
>> should be inside your template directory where you installed your template.
>>
>> I had faced  this issue, but resolved it too. Let me know with your app
>> list screenshot and corresponding engine.json
>>
>> Thanks
>>
>> On Wed, Apr 19, 2017 at 8:45 AM, Ravi Kiran <ravi.gunale@gmail.com>
>> wrote:
>>
>>> @Vaghawan, I have updated app_name in engine.json . And then 'pio Build'
>>> and evaluation query. Still this issue exists
>>>
>>>
>>> On 19-Apr-2017 8:14 AM, "Vaghawan Ojha" <vaghawan781@gmail.com> wrote:
>>>
>>> Hi,
>>>
>>> It seems you haven't changed the app name in your engine.json. There is
>>> an engine.json in your template directory, please make sure that you have
>>> changed that name.
>>>
>>> And it will works. Make sure you input the right appname in your
>>> engine.json.
>>>
>>> Thanks
>>>
>>>
>>> On Wed, Apr 19, 2017 at 5:33 AM, Ravi Kiran <ravi.gunale@gmail.com>
>>> wrote:
>>>
>>>> Hi,
>>>> When I try to evaluate I am getting following error.
>>>>
>>>>
>>>> [ERROR] [Common$] Invalid app name INVALID_APP_NAME
>>>> Exception in thread "main" java.lang.IllegalArgumentException: Invalid
>>>> app name INVALID_APP_NAME
>>>>
>>>>
>>>> I have updated app name in engine.json
>>>> This app is in 'pio app list'
>>>> I have also done 'pio build', 'pio train' and 'pio deploy' before
>>>> running evaluation query.
>>>>
>>>>
>>>> Can you please help me resolve this query?
>>>>
>>>> Thanks
>>>>
>>>
>>>
>>>
>>
>

Mime
View raw message