predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pat Ferrel <...@occamsmachete.com>
Subject Re: Invalid app name INVALID_APP_NAME
Date Wed, 19 Apr 2017 14:32:44 GMT
Templates are not part of the PredictionIO, they are often supported by their authors. Check
the Template gallery, there should be a support link for each Template, some are Apache, some
are supported by their authors. Their may be a github issues link there for author support.

Not all Templates support evaluation so make sure the hardcoded name does not indicate lack
of support. 


On Apr 18, 2017, at 10:19 PM, Ravi Kiran <ravi.gunale@gmail.com> wrote:

@Vaghawan, Issue is sorted out. I dont know for some reason app name was hardcoded (as "INVALID_APP_NAME")
in template I am using. I changed that name to my app name and it worked. 
Link of template I am using https://github.com/apache/incubator-predictionio-template-attribute-based-classifier/blob/develop/src/main/scala/Evaluation.scala
<https://github.com/apache/incubator-predictionio-template-attribute-based-classifier/blob/develop/src/main/scala/Evaluation.scala>,
Line 27

This is not the way it should be hardcoded or am I missing something?

On Wed, Apr 19, 2017 at 9:10 AM, Vaghawan Ojha <vaghawan781@gmail.com <mailto:vaghawan781@gmail.com>>
wrote:
Ya I see! the pio path shouldn't be the problem. But you can easily export the pio path. 

Ya, you can stick with the same pio, but could create new app from scratch, like downloading
the template and creating a new pio app and changing engine.json. 

Hope  this should work. 

On Wed, Apr 19, 2017 at 9:22 AM, Ravi Kiran <ravi.gunale@gmail.com <mailto:ravi.gunale@gmail.com>>
wrote:

I am running "pio build" from template dir.  But pio path is not configured. So, everytime
I have to give absolute path of pio. Could that be a problem (But most queries are working).

For e.g.
 ../bin/pio build
../bin/pio eval mlframework.AccuracyEvaluation mlframework.EngineParamsList
../bin app list

I will made new app right from scratch, even then this issue persists :(

On Wed, Apr 19, 2017 at 9:00 AM, Vaghawan Ojha <vaghawan781@gmail.com <mailto:vaghawan781@gmail.com>>
wrote:
Hi, 

This seems fine, did you make sure to run pio build from that template dir? In case still
not working, I would suggest you to delete the wineapp(if you haven't imported the events
yet) and recreate a app, and change the engine.json and build again. 

I had this problem with both MyRecommendation and Universal Recommender as well, in case of
MyRecommendation, I rebuilt the app and it worked. 

Please try that, it may work for you as well. 

Thanks

On Wed, Apr 19, 2017 at 9:05 AM, Ravi Kiran <ravi.gunale@gmail.com <mailto:ravi.gunale@gmail.com>>
wrote:
[INFO] [App$]                 Name |   ID |                                              
        Access Key | Allowed Event(s)
[INFO] [App$]                app10 |   10 |                                              
           mnbvcxz | (all)
[INFO] [App$]         sample_app10 |   11 |                                              
              1234 | (all)
[INFO] [App$]         sample_app21 |   13 |                                              
              4321 | (all)
[INFO] [App$]         sample_app22 |   14 |                                              
          4321abcd | (all)
[INFO] [App$]         sample_app23 |   15 |                                              
         4321abcde | (all)
[INFO] [App$]         sample_app26 |   18 |                                              
       4321abcdefg | (all)
[INFO] [App$]              wineapp |   19 |                                              
       wineappeine | (all)
[INFO] [App$] Finished listing 19 app(s).
 

This is output of pio app list

On Wed, Apr 19, 2017 at 8:42 AM, Ravi Kiran <ravi.gunale@gmail.com <mailto:ravi.gunale@gmail.com>>
wrote:
Contents of engine.json

{
  "id": "default",
  "description": "Default settings",
  "engineFactory": "mlframework.ClassificationEngine",
  "datasource": {
    "params": {
      "appName": "wineapp"
    }
  },
  "algorithms": [
    {
      "name": "naive",
      "params": {
        "lambda": 1.0
      }
    }
  ]
}


Location of engine.json
/home/user_name/Documents/code/apache-predictionio-0.10.0-incubating/PredictionIO-0.10.0-incubating/sample_classifier/engine.json
I have installed template in sample_classifier folder




On Wed, Apr 19, 2017 at 8:32 AM, Vaghawan Ojha <vaghawan781@gmail.com <mailto:vaghawan781@gmail.com>>
wrote:
What does your pio app list produce? 

And can you also send a screenshot of your engine.json. This engine.json should be inside
your template directory where you installed your template. 

I had faced  this issue, but resolved it too. Let me know with your app list screenshot and
corresponding engine.json

Thanks

On Wed, Apr 19, 2017 at 8:45 AM, Ravi Kiran <ravi.gunale@gmail.com <mailto:ravi.gunale@gmail.com>>
wrote:
@Vaghawan, I have updated app_name in engine.json . And then 'pio Build' and evaluation query.
Still this issue exists


On 19-Apr-2017 8:14 AM, "Vaghawan Ojha" <vaghawan781@gmail.com <mailto:vaghawan781@gmail.com>>
wrote:
Hi, 

It seems you haven't changed the app name in your engine.json. There is an engine.json in
your template directory, please make sure that you have changed that name. 

And it will works. Make sure you input the right appname in your engine.json. 

Thanks


On Wed, Apr 19, 2017 at 5:33 AM, Ravi Kiran <ravi.gunale@gmail.com <mailto:ravi.gunale@gmail.com>>
wrote:
Hi, 
When I try to evaluate I am getting following error.


[ERROR] [Common$] Invalid app name INVALID_APP_NAME
Exception in thread "main" java.lang.IllegalArgumentException: Invalid app name INVALID_APP_NAME


I have updated app name in engine.json
This app is in 'pio app list'
I have also done 'pio build', 'pio train' and 'pio deploy' before running evaluation query.


Can you please help me resolve this query?

Thanks











Mime
View raw message