predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cristina Giannone <cristina.giann...@gmail.com>
Subject Re: predictionIO classpath
Date Thu, 06 Oct 2016 07:38:48 GMT
Many thanks :-)
Cristina

2016-10-06 3:51 GMT+02:00 Donald Szeto <donald@apache.org>:

> Hi Cristina,
>
> If you are using 0.9.x, you can keep using the old "io.prediction" package
> name for your engine source code. When you follow the tutorial online, just
> use "io.prediction" in place of "org.apache.predictionio" wherever you come
> across it.
>
> If you are trying 0.10.0 though, make sure you remove
> "project/pio-build.sbt" from your engine source code, and replace
> "pioVersion.value" in "build.sbt" with "0.10.0-SNAPSHOT".
>
> Sorry again for the confusion. We are hoping to release 0.10.0 officially
> this Friday.
>
> Regards,
> Donald
>
> On Wed, Oct 5, 2016 at 6:57 AM, Cristina Giannone <
> cristina.giannone@gmail.com> wrote:
>
>> Hi,
>> sorry for my continuous questions..
>>
>> I've installed the pio version 0.10, but when I try to build a template
>> the result it's the same...
>>
>>
>> [INFO] [Console$] [info] Loading project definition from
>> /opt/PredictionIO-0.10.0-SNAPSHOT/MyRec/filter-by-category/project
>> [INFO] [Console$] [info] Updating {file:/opt/PredictionIO-0.10.0
>> -SNAPSHOT/MyRec/filter-by-category/project/}filter-by-category-build...
>> [INFO] [Console$] [info] Resolving org.apache.predictionio#pio-build;0.9.0
>> ...
>>                   [info] Resolving org.apache.predictionio#pio-build;0.9.0
>> ...
>> [INFO] [Console$] [warn]     module not found:
>> org.apache.predictionio#pio-build;0.9.0
>> [INFO] [Console$] [warn] ==== typesafe-ivy-releases: tried
>> [INFO] [Console$] [warn]   https://repo.typesafe.com/type
>> safe/ivy-releases/org.apache.predictionio/pio-build/scala_
>> 2.10/sbt_0.13/0.9.0/ivys/ivy.xml
>> [INFO] [Console$] [warn] ==== sbt-plugin-releases: tried
>> [INFO] [Console$] [warn]   https://repo.scala-sbt.org/sca
>> lasbt/sbt-plugin-releases/org.apache.predictionio/pio-build/
>> scala_2.10/sbt_0.13/0.9.0/ivys/ivy.xml
>> [INFO] [Console$] [warn] ==== local: tried
>> [INFO] [Console$] [warn]   /home/cgiannone/.ivy2/local/or
>> g.apache.predictionio/pio-build/scala_2.10/sbt_0.13/0.9.0/ivys/ivy.xml
>> [INFO] [Console$] [warn] ==== public: tried
>> [INFO] [Console$] [warn]   https://repo1.maven.org/maven2
>> /org/apache/predictionio/pio-build_2.10_0.13/0.9.0/pio-build-0.9.0.pom
>> [INFO] [Console$] [info] Resolving com.eed3si9n#sbt-assembly;0.11.2 ...
>>                   [info] Resolving org.scala-lang#scala-library;2.10.4
>> ...
>>
>> ....
>>
>> If I put these addresses into a browser the reply is "404 not found"...
>> :-(
>> Is maybe a problem of resource location?
>>
>> Best,
>> Cristina
>>
>>
>>
>> 2016-10-05 10:56 GMT+02:00 Cristina Giannone <cristina.giannone@gmail.com
>> >:
>>
>>> I didn't install pio 0,10 yet.
>>> I'll do that if it is mandatory.
>>>
>>> Sorry for the confusion ;-)
>>>
>>> Many thanks,
>>> Cristina
>>>
>>> 2016-10-05 10:50 GMT+02:00 Kenneth Chan <kenneth@apache.org>:
>>>
>>>> i meant did you also install PIO from source code (dev branch) and run
>>>> make-distribution.sh as described by Chan?
>>>>
>>>> On Wednesday, October 5, 2016, Cristina Giannone <
>>>> cristina.giannone@gmail.com> wrote:
>>>>
>>>>> I modified the the classpaths in build.sbt and in the scala file as
>>>>> suggested by Chan.
>>>>>
>>>>> But whitout change the predictioIO version (0.9.6).
>>>>> Must I update to the 0.10 version in order to use this new classpath?
>>>>>
>>>>> Many thanks,
>>>>> Cristina
>>>>>
>>>>
>>>
>>
>

Mime
View raw message