predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bansari Shah <bansari.ja...@gmail.com>
Subject Re: Error in pio status
Date Tue, 11 Oct 2016 14:51:34 GMT
Hi Donald,

Thank you, Yes, it was problem of zookeeper not getting started. I am using
embedded zookeeper.  Clearing zookeeper data and restarting system helps to
solve this problem.

Thank you

Regards,
Bansari

On Tue, Oct 11, 2016 at 2:55 AM, Donald Szeto <donald@apache.org> wrote:

> Hi Bansari,
>
> Looks like the underlying problem is ZooKeeper not being able to start.
> Are you using the embedded ZooKeeper or a standalone ZooKeeper cluster? If
> you could afford it, it might help to clear the ZooKeeper data and try
> again.
>
> Regards,
> Donald
>
> On Mon, Oct 10, 2016 at 1:24 AM, Bansari Shah <bansari.jan93@gmail.com>
> wrote:
>
>> While configuring predictinIO-0.10.0, after running pio-start-all,
>> runnnig pio status shows below error :
>>
>> [ERROR] [RecoverableZooKeeper] ZooKeeper exists failed after 1 attempts
>> [ERROR] [ZooKeeperWatcher] hconnection-0x716e431d, quorum=localhost:2181,
>> baseZNode=/hbase Received unexpected KeeperException, re-throwing exception
>> [WARN] [ZooKeeperRegistry] Can't retrieve clusterId from Zookeeper
>> [ERROR] [StorageClient] Cannot connect to ZooKeeper (ZooKeeper ensemble:
>> localhost). Please make sure that the configuration is pointing at the
>> correct ZooKeeper ensemble. By default, HBase manages its own ZooKeeper, so
>> if you have not configured HBase to use an external ZooKeeper, that means
>> your HBase is not started or configured properly.
>> [ERROR] [Storage$] Error initializing storage client for source HBASE
>> [ERROR] [Console$] Unable to connect to all storage backends
>> successfully. The following shows the error message from the storage
>> backend.
>> [ERROR] [Console$] Data source HBASE was not properly initialized.
>> (org.apache.predictionio.data.storage.StorageClientException)
>> [ERROR] [Console$] Dumping configuration of initialized storage backend
>> sources. Please make sure they are correct.
>> [ERROR] [Console$] Source Name: ELASTICSEARCH; Type: elasticsearch;
>> Configuration: HOSTS -> localhost, TYPE -> elasticsearch, HOME ->
>> /Users/bansarishah/Documents/PredictionIO-0.11.0-SNAPSHOT/vendors/elasticsearch-1.7.1,
>> PORTS -> 9300
>> [ERROR] [Console$] Source Name: PGSQL; Type: jdbc; Configuration: URL ->
>> jdbc:postgresql://localhost/pio, PASSWORD -> postgres, TYPE -> jdbc,
>> USERNAME -> postgres
>> [ERROR] [Console$] Source Name: HBASE; Type: (error); Configuration:
>> (error)
>>
>>
>>
>> to tried to solve this by running r ' jps' and killed running process of
>> HMaster with 'kill -9 pid' and again did pio-stop-all and again started
>> pio. I repeated it many times, still issue is not getting resolved.
>>
>> Please suggest any other solutions.
>>
>> Thank you
>>
>> Regards,
>> Bansari
>>
>
>

Mime
View raw message