predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jenna Kwon <jinkwo...@gmail.com>
Subject NameError: uninitialized constant Net::HTTPCreated ?
Date Mon, 12 Sep 2016 21:17:28 GMT
Hello!

I am following this guide here
<http://predictionio.incubator.apache.org/demo/tapster/> and am getting
error pasted below.

rake aborted!

NameError: uninitialized constant Net::HTTPCreated

/Library/Ruby/Gems/2.0.0/gems/predictionio-0.9.0/lib/predictionio/event_client.rb:326:in
`sync_events'

/Library/Ruby/Gems/2.0.0/gems/predictionio-0.9.0/lib/predictionio/event_client.rb:132:in
`create_event'

/Users/JennaKwon/PredictionIO/Demo-Tapster/lib/tasks/import/predictionio.rake:54:in
`block (3 levels) in <top (required)>'

/Users/JennaKwon/PredictionIO/Demo-Tapster/lib/tasks/import/predictionio.rake:48:in
`each'

/Users/JennaKwon/PredictionIO/Demo-Tapster/lib/tasks/import/predictionio.rake:48:in
`each_with_index'

/Users/JennaKwon/PredictionIO/Demo-Tapster/lib/tasks/import/predictionio.rake:48:in
`block (2 levels) in <top (required)>'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:240:in `call'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:240:in `block in
execute'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:235:in `each'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:235:in `execute'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:179:in `block in
invoke_with_call_chain'

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/monitor.rb:211:in
`mon_synchronize'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:172:in
`invoke_with_call_chain'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/task.rb:165:in `invoke'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:150:in
`invoke_task'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:106:in
`block (2 levels) in top_level'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:106:in
`each'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:106:in
`block in top_level'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:115:in
`run_with_threads'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:100:in
`top_level'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:78:in
`block in run'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:176:in
`standard_exception_handling'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/lib/rake/application.rb:75:in
`run'

/Library/Ruby/Gems/2.0.0/gems/rake-10.4.2/bin/rake:33:in `<top (required)>'

/usr/bin/rake:23:in `load'

/usr/bin/rake:23:in `<top (required)>'
This happens when I try to post data to the predictionIO by executing "rake
import:predictionio".
I am not sure how to trace through the code with this.
Has anyone experienced this bug?

Best Regards,
Jenna Kwon

-- 
Jenna Kwon
B.S. Computer Science '17| Georgia Institute of Technology
Denning Technology and Management Scholar
GT Tennis Club | GT Trailblazers
www.jennakwon.com
(541)908-2963

Mime
View raw message