predictionio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Szeto <don...@apache.org>
Subject Re: predictionio.NotCreatedError: Exception happened: [Errno 111] Connection refused for request POST /
Date Fri, 01 Jul 2016 17:10:32 GMT
If it's the first time build, it's possible that SBT is downloading a lot
of dependencies. Remember we used to ask people to put the --verbose flag
to make sure? I recall advising the user to add this flag in another
thread. Still waiting to hear back.

On Fri, Jul 1, 2016 at 10:07 AM, Pat Ferrel <pat@occamsmachete.com> wrote:

> Any idea why he is having a build failure then? Some user error?
>
>
> On Jul 1, 2016, at 10:05 AM, Donald Szeto <donald@apache.org> wrote:
>
> The upgrade checker is implemented to run in a separate thread and should
> not fail the main process, be it building, training, or deploying. I
> suggest this be temporarily disabled until our Apache migration is complete
> and stable.
>
> On Fri, Jul 1, 2016 at 10:01 AM, Pat Ferrel <pat@occamsmachete.com
> <mailto:pat@occamsmachete.com>> wrote:
> Shouldn’t all exceptions (well the vast majority) be caught in that code
> so no error would cause a failure of a build?
>
>
> On Jul 1, 2016, at 9:55 AM, Pat Ferrel <pat@occamsmachete.com <mailto:
> pat@occamsmachete.com>> wrote:
>
> io.prediction.workflow.UpgradeCheckRunner.run(WorkflowUtils.scala:400) ????
>
> Seems to be looking for  "http://direct.prediction.io/ <
> http://direct.prediction.io/>"
>
> Two types of exceptions are caught, not sure what happens with any others.
> Does this mean that if the site is wonky builds may fail? If so is anyone
> working on this?
>
> Begin forwarded message:
>
> From: Akshay Kolte <akshaykolte17@gmail.com <mailto:
> akshaykolte17@gmail.com>>
> Subject: Re: predictionio.NotCreatedError: Exception happened: [Errno 111]
> Connection refused for request POST /
> Date: July 1, 2016 at 9:06:35 AM PDT
> To: actionml-user <actionml-user@googlegroups.com <mailto:
> actionml-user@googlegroups.com>>
> Cc: pat@occamsmachete.com <mailto:pat@occamsmachete.com>
>
> I suppose the installation was missing something. pio status was showing
> success though. I installed pio again using the single bash curl statement.
>
> That error has been resolved. However now the build stops saying the
> following SSL error:
>
>
> Exception in thread "Thread-0" javax.net.ssl.SSLHandshakeException:
> sun.security.validator.ValidatorException: PKIX path building failed:
> sun.security.provider.certpath.SunCertPathBuilderException: unable to find
> valid certification path to requested target
>     at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
>     at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949)
>     at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302)
>     at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296)
>     at
> sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1509)
>     at
> sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216)
>     at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979)
>     at sun.security.ssl.Handshaker.process_record(Handshaker.java:914)
>     at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062)
>     at
> sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
>     at
> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
>     at
> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
>     at
> sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
>     at
> sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
>     at
> sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1513)
>     at
> sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)
>     at
> sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
>     at java.net.URL.openStream(URL.java:1045)
>     at scala.io.Source$.fromURL(Source.scala:140)
>     at scala.io.Source$.fromURL(Source.scala:130)
>     at
> io.prediction.workflow.UpgradeCheckRunner.run(WorkflowUtils.scala:400)
>     at java.lang.Thread.run(Thread.java:745)
> Caused by: sun.security.validator.ValidatorException: PKIX path building
> failed: sun.security.provider.certpath.SunCertPathBuilderException: unable
> to find valid certification path to requested target
>     at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:387)
>     at
> sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292)
>     at sun.security.validator.Validator.validate(Validator.java:260)
>     at
> sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324)
>     at
> sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229)
>     at
> sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)
>     at
> sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1491)
>     ... 17 more
> Caused by: sun.security.provider.certpath.SunCertPathBuilderException:
> unable to find valid certification path to requested target
>     at
> sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)
>     at
> sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)
>     at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280)
>     at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:382)
>     ... 23 more
>
>
> The build doesn't finish. Any help regarding the following?
>
>
> On Friday, July 1, 2016 at 8:29:49 PM UTC+5:30, Pat Ferrel wrote:
> The script is failing to import, usually this is because the correct
> Python packages are not available or the EventServer is not running.
>
> what does `pio status` say before the integration test is run?
>
> On Jul 1, 2016, at 7:10 AM, Akshay Kolte <akshay...@gmail.com <>> wrote:
>
> Hi Pat,
>
> We followed exact steps given on link (
> http://www.actionml.com/docs/ur_quickstart <
> http://www.actionml.com/docs/ur_quickstart>), with recommended pip &
> python versions. (repeated the process on two separate machines)
> Still facing the same error.
>
> --
>
> On Friday, July 1, 2016 at 6:30:40 PM UTC+5:30, Pat Ferrel wrote:
> This error is because of an incomplete Template install, you need python,
> pip, and the packages used in the import script:
> http://www.actionml.com/docs/ur_quickstart <
> http://www.actionml.com/docs/ur_quickstart>
> On Jul 1, 2016, at 3:22 AM, Akshay Kolte <akshay...@gmail.com <>> wrote:
>
> I have installed pio from actionml install guide here:
> https://github.com/actionml/cluster-setup/blob/master/install.md <
> https://github.com/actionml/cluster-setup/blob/master/install.md>
>
> I  have not installed elastisearch and pio status runs with success.
>
> However when I run the integration-test as mentioned here:
> https://github.com/actionml/template-scala-parallel-universal-recommendation#quickstart
> <
> https://github.com/actionml/template-scala-parallel-universal-recommendation#quickstart
> >
>
> I get the following error :
>
> Importing data for integration test
> Access key:
> Ycv-Y4zTDLUXHsEzIXgNMk9c0PACV-4z0MvOVLLP004EDAZKph-cQPfCE06KvqJu
> Namespace(access_key='Ycv-Y4zTDLUXHsEzIXgNMk9c0PACV-4z0MvOVLLP004EDAZKph-cQPfCE06KvqJu',
> file='./data/sample-handmade-data.txt', url='http://localhost:7070' <
> http://localhost:7070'>)
> Importing data...
> Traceback (most recent call last):
>   File "examples/import_handmade.py", line 113, in <module>
>     import_events(client, args.file)
>   File "examples/import_handmade.py", line 43, in import_events
>     event_time = current_date
>   File "/usr/local/lib/python2.7/dist-packages/predictionio/__init__.py",
> line 247, in create_event
>     event_time).get_response()
>   File
> "/usr/local/lib/python2.7/dist-packages/predictionio/connection.py", line
> 111, in get_response
>     self._response = self.rfunc(tmp_response)
>   File "/usr/local/lib/python2.7/dist-packages/predictionio/__init__.py",
> line 118, in _acreate_resp
>     (response.error, response.request))
> predictionio.NotCreatedError: Exception happened: [Errno 111] Connection
> refused for request POST
> /events.json?accessKey=Ycv-Y4zTDLUXHsEzIXgNMk9c0PACV-4z0MvOVLLP004EDAZKph-cQPfCE06KvqJu
> {'eventTime': '2016-07-01T10:18:38.638+0000', 'entityType': 'user',
> 'targetEntityType': 'item', 'targetEntityId': 'Iphone 6', 'entityId': 'u1',
> 'event': 'purchase'}
> /events.json?accessKey=Ycv-Y4zTDLUXHsEzIXgNMk9c0PACV-4z0MvOVLLP004EDAZKph-cQPfCE06KvqJu?eventTime=2016-07-01T10%3A18%3A38.638%2B0000&entityType=user&targetEntityType=item&targetEntityId=Iphone+6&entityId=u1&event=purchase
>
>
> Can anybody help with the error ?
>
> Thanks.
> New at using the actionml UR.
>
> --
> You received this message because you are subscribed to the Google Groups
> "actionml-user" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to actionml-use...@googlegroups.com <>.
> To post to this group, send email to action...@googlegroups.com <>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/actionml-user/d6e86465-0081-44da-8662-f158a66f4f5c%40googlegroups.com
> <
> https://groups.google.com/d/msgid/actionml-user/d6e86465-0081-44da-8662-f158a66f4f5c%40googlegroups.com?utm_medium=email&utm_source=footer
> >.
> For more options, visit https://groups.google.com/d/optout <
> https://groups.google.com/d/optout>.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "actionml-user" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to actionml-use...@googlegroups.com <>.
> To post to this group, send email to action...@googlegroups.com <>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/actionml-user/3975dcb4-6349-4baa-9b51-0746e350b8d4%40googlegroups.com
> <
> https://groups.google.com/d/msgid/actionml-user/3975dcb4-6349-4baa-9b51-0746e350b8d4%40googlegroups.com?utm_medium=email&utm_source=footer
> >.
> For more options, visit https://groups.google.com/d/optout <
> https://groups.google.com/d/optout>.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "actionml-user" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to actionml-user+unsubscribe@googlegroups.com <mailto:
> actionml-user+unsubscribe@googlegroups.com>.
> To post to this group, send email to actionml-user@googlegroups.com
> <mailto:actionml-user@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/actionml-user/6961e480-b16c-4d2f-81e4-24c80c437cc5%40googlegroups.com
> <
> https://groups.google.com/d/msgid/actionml-user/6961e480-b16c-4d2f-81e4-24c80c437cc5%40googlegroups.com?utm_medium=email&utm_source=footer
> >.
> For more options, visit https://groups.google.com/d/optout <
> https://groups.google.com/d/optout>.
>
>
>
>
>

Mime
View raw message