portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ricky Frost" <ricky.fr...@pobox.com>
Subject RE: Q about jsp portion of testportlet
Date Tue, 20 Apr 2004 18:25:50 GMT
Question answered:

I downloaded Tomcat 4.1.30 binaries
I downloaded and built ws-wsrp4j source from cvs
All of the above using JDK 1.3.1_06

It works!


-----Original Message-----
From: Ricky Frost [mailto:ricky.frost@pobox.com]
Sent: Monday, April 19, 2004 6:48 PM
To: wsrp4j-user@ws.apache.org
Subject: Q about jsp portion of testportlet


I'm trying to setup the wsrp4j consumer and producer reference. I've
followed all the instructions on the project website. When I run the
SwingConsumer the portlet frames are all empty. The monitor shows that the
markup came back empty in the response and the tomcat console shows the
messages below. What am I doing wrong?

Any help appreciated.
p.s. I'm using Tomcat binary download 5.0.19, JDK 1.4.2_03 and I picked up
WSRP4J source on 3/26/04 and built everything then. If it is known not to
work with these then can someone specify which versions of everything I
should be using...


TOMCAT CONSOLE FRAGMENT
......
Apr 19, 2004 4:52:55 PM org.apache.catalina.core.StandardHostDeployer
install
INFO: Installing web application at context path /webdav from URL
file:C:\ws-tomcat-5.0.19\webapps\webdav
Apr 19, 2004 4:52:55 PM org.apache.catalina.core.StandardHostDeployer
install
INFO: Installing web application at context path /wsrp from URL
file:C:\ws-tomcat-5.0.19\webapps\wsrp
Apr 19, 2004 4:52:56 PM org.apache.catalina.core.StandardHostDeployer
install
INFO: Installing web application at context path /wsrptest from URL
file:C:\ws-tomcat-5.0.19\webapps\wsrptest
Apr 19, 2004 4:52:56 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8080
Apr 19, 2004 4:52:57 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8009
Apr 19, 2004 4:52:57 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=20/71
config=C:\ws-tomcat-5.0.19\conf\jk2.properties
Apr 19, 2004 4:52:57 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 14862 ms

Apr 19, 2004 5:04:22 PM org.apache.pluto.portalImpl.services.log.LoggerImpl
error
SEVERE: ServletContext '/wsrptest' not found!
Apr 19, 2004 5:04:22 PM org.apache.pluto.portalImpl.services.log.LoggerImpl
error
SEVERE: PortletInvokerImpl.action() - Unable to find RequestDispatcher.

(these are repeated)


Mime
View raw message