portals-pluto-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Scott Nicklous <Scott.Nickl...@de.ibm.com>
Subject Re: Pluto in Eclipse
Date Fri, 11 Oct 2013 12:36:53 GMT
Hi David, thanks for the tip.

After some judicious trying things out, it looks like the problems only
occur during automatic builds and after the initial import of the project
into the workspace. I turned off the automatic build for the workspace and
can live with the the error that comes up when the project has been newly
imported.

So I think I'm in business ...

regards,
Scott




David Taylor <davidseantaylor@gmail.com> wrote on 10.10.2013 17:52:49:

> From: David Taylor <davidseantaylor@gmail.com>
> To: pluto-dev@portals.apache.org,
> Date: 10.10.13 17:53
> Subject: Re: Pluto in Eclipse
>
> I don't edit with Eclipse. With IntelliJ I just open the root
> pom.xml file. Did you try "mvn eclipse:eclipse"
>
> Here is the output I got from that command, which gives you Eclipse
> .classpath files for most of the source:
>
> [INFO] Wrote Eclipse project for "maven-pluto-plugin" to /Users/
> dtaylor/apache/portals/pluto/maven-pluto-plugin.
> [INFO]
> [INFO]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building Apache Pluto Testsuite Portlet 2.1.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [WARNING] Failed to retrieve plugin descriptor for
> org.apache.portals.pluto:maven-pluto-plugin:2.1.0-SNAPSHOT: Plugin
> org.apache.portals.pluto:maven-pluto-plugin:2.1.0-SNAPSHOT or one of
> its dependencies could not be resolved: Could not find artifact
> org.apache.portals.pluto:maven-pluto-plugin:jar:2.1.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Apache Pluto ...................................... SUCCESS
[0.911s]
> [INFO] Apache Pluto Container API ........................ SUCCESS
[0.078s]
> [INFO] Apache Pluto Portlet Container .................... SUCCESS
[1.566s]
> [INFO] Apache Pluto Portlet Tag Library .................. SUCCESS
[0.039s]
> [INFO] Apache Pluto Container Driver API ................. SUCCESS
[0.050s]
> [INFO] Apache Pluto Portal Driver ........................ SUCCESS
[1.502s]
> [INFO] Apache Pluto Portal Driver Implementation Classes . SUCCESS
[1.205s]
> [INFO] Apache Pluto Portal ............................... SUCCESS
[0.801s]
> [INFO] Apache Pluto Utilities ............................ SUCCESS
[0.068s]
> [INFO] Maven Pluto Installer Plugin ...................... SUCCESS
[2.253s]
> [INFO] Apache Pluto Testsuite Portlet .................... FAILURE
[0.019s]
> [INFO] Apache Pluto Ant Tasks ............................ SKIPPED
> [INFO] Apache Pluto Website Skin ......................... SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 9.966s
> [INFO] Finished at: Thu Oct 10 08:48:48 PDT 2013
> [INFO] Final Memory: 22M/336M
>
>

> --
> David


Mime
View raw message