portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Strickland" <stric...@gmail.com>
Subject Re: "simplest" portlet
Date Sat, 08 Mar 2008 17:37:04 GMT
Can you post the web.xml so we can see if something is wrong with it?

On Sat, Mar 8, 2008 at 2:16 AM, sumeet khullar <khullar.sumeet@gmail.com>
wrote:

>
> Even I am facing the same problem getting the simplest portlet at
> http://portals.apache.org/jetspeed-2/guides/guide-simple-portlet.html to
> work.
>
> When I run the tomcat server, the demo portlets are deployed , but when
> when
> it tries to deploy the simplest portlet, it gives the following exception:
>
> ERROR: java.lang.IllegalArgumentException: WEB-INF/web.xml
> org.apache.jetspeed.deployment.DeploymentException:
> java.lang.IllegalArgumentException: WEB-INF/web.xml
>        at
>
> org.apache.jetspeed.deployment.impl.DeployPortletAppEventListener.deployPortletApplication
> (DeployPortletAppEventListener.java:224)
>        at
>
> org.apache.jetspeed.deployment.impl.DeployPortletAppEventListener.invokeDeploy
> (DeployPortletAppEventListener.java:209)
>        at
> org.apache.jetspeed.deployment.impl.StandardDeploymentManager.dispatch(
> StandardDeploymentManager.java:264)
>        at
> org.apache.jetspeed.deployment.impl.StandardDeploymentManager.deploy(
> StandardDeploymentManager.java:178)
>        at
>
> org.apache.jetspeed.deployment.impl.StandardDeploymentManager.fireDeploymentEvent
> (StandardDeploymentManager.java:209)
>        at
>
> org.apache.jetspeed.deployment.impl.StandardDeploymentManager$FileSystemScanner.run
> (StandardDeploymentManager.java:357)
> Caused by: java.lang.IllegalArgumentException: WEB-INF/web.xml
>        at
> org.apache.jetspeed.tools.deploy.JetspeedDeploy.<init>(JetspeedDeploy.java
> :164)
>        at
> org.apache.jetspeed.tools.deploy.JetspeedDeploy.<init>(JetspeedDeploy.java
> :88)
>        at
>
> org.apache.jetspeed.deployment.impl.DeployPortletAppEventListener.deployPortletApplication
> (DeployPortletAppEventListener.java:219)
>        ... 5 more
> ERROR: Failure deploying
> /root/Jetspeed-2.1.3/webapps/jetspeed/WEB-INF/deploy/simplest.war
>
> I have checked web.xml and also checked by war file, but am unable to
> figure
> out the problem. Any help would be appreciated!
>
> Sumeet
>
> David Sean Taylor wrote:
> >
> >
> > On Aug 9, 2007, at 10:41 AM, Redman, Greg wrote:
> >
> >> I have followed the on-line documentation at
> >> http://portals.apache.org/jetspeed-2/guides/guide-simple-portlet.html
> >>
> >> and haven't been able to get this to work.   I receive "Failed to
> >> retrieve Portlet Definition for simplest::Simplest" in the portlet
> >> pane.
> >>
> >> According to the message archive, this was also reported back on March
> >> 9, 2006.
> >>
> >>
> >>
> >> Does anyone have a resolution for this error?
> >>
> >
> >
> > If you login as Admin, go to the PALM Adminstrative portlet
> > Do you see an application named "simplest" there?
> > If yes, what is its status?
> >
> > If all else fails email me your war file and I should be able to
> > figure it out in a few minutes
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
> > For additional commands, e-mail: jetspeed-user-help@portals.apache.org
> >
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/Re%3A-%22simplest%22-portlet-tp12077120p15911963.html
> Sent from the Jetspeed - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-user-help@portals.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message