portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Psiuk" <apa...@salesfactory.org>
Subject AW: Faces Portlets and Jetspeed decorators
Date Wed, 19 Mar 2008 16:54:20 GMT
are you running js1.x or js2.x?
 

-----Ursprüngliche Nachricht-----
Von: David Dyer [mailto:ddyer@artifact-software.com] 
Gesendet: Mittwoch, 19. März 2008 15:01
An: Jetspeed Users List
Betreff: Faces Portlets and Jetspeed decorators

Hi everyone.

I'm trying to add a portlet in the header.vm of my decorator. I've 
already successfully added generic portlets to the header with:

 $jetspeed.renderPortletEntity("MyPortlet", 
"my-portletApplication::MyPortletName).

This has worked fine, but when I attempt it with a faces portlet, the 
portlet displays alright, but the processAction from the action listener 
is never invoked when the commandLink is clicked.

The portlet has also been tested by referencing it in a psml as would be 
normal, and it works as expected there.

Here's the portlet reference from the appropriate portlet xml.

<portlet>
        <description>Portlet description yadda yadda yadda</description>
        <portlet-name>MyPortletName</portlet-name>
        <display-name>My Portlet Name</display-name>
        
 <portlet-class>org.apache.portals.bridges.jsf.FacesPortlet</portlet-class>
        <init-param>
            <name>ViewPage</name>
            <value>/myportlet.jsp</value>
        </init-param>      
        <expiration-cache>0</expiration-cache>
        <supports>
            <mime-type>text/html</mime-type>
            <portlet-mode>VIEW</portlet-mode>
        </supports>
        <supported-locale>en</supported-locale>
        
<resource-bundle>my.package.ressources.myRessourceBundle</resource-bundle>
        <portlet-info>
            <title>My Portlet Name</title>
            <short-title>Portlet</short-title>
            <keywords>My, Portlet, Name</keywords>
        </portlet-info>
        <portlet-preferences>
        </portlet-preferences>
    </portlet>


Has anyone had any experience with this?

Thanks in advance,

David




---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-user-help@portals.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-user-help@portals.apache.org


Mime
View raw message