portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Chaney <a...@writingshow.com>
Subject Re: jetspeed-2.1.3 not working in apache-tomcat-5.5.17
Date Tue, 19 Feb 2008 18:17:54 GMT
Stefano Minichiello wrote:
> jetspeed-2.1.3.war is not working in apache-tomcat-5.5.17 . I am getting
> below error.
>  
>
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.digester.Digester.sax).
>
>   
The first thing to do is to fix the logger problem. Tomcat's logging is 
telling you that it can't find a correct log4j setup
. The fact that it mentions org.apache.commons.digester.Digester means 
that it is more to do with Tomcat than Jetspeed, because that class is 
used to process the xml files used to define tomcat's operations.

Probably there are a lot of other error messages but you can't see them 
because the logger isn't logging...

See
http://tomcat.apache.org/tomcat-5.5-doc/logging.html

for a detailed description of how Tomcat logging is setup.


> log4j:WARN Please initialize the log4j system properly.
>
>   
Yep...
> 19-feb-2008 15.24.14 org.apache.catalina.core.StandardContext start
>   
GRAVE: Error listenerStart

When you have the logging working you will probably be able to work this 
bit out.

> 19-feb-2008 15.24.14 org.apache.catalina.core.StandardContext start
>
> GRAVE: Context [/jetspeed] startup failed due to previous errors
>
>  
>
> is there anyone that can help me?
>
>  
>
> Thanks
>
>
>
> !DSPAM:47baeae1319961336712104!
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-user-help@portals.apache.org


Mime
View raw message