portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weaver, Scott" <weav...@ugs.com>
Subject RE: Running J2 in Eclipse
Date Tue, 30 Oct 2007 15:20:30 GMT
Hi Eugene,

I run Jetspeed from inside Eclipse using Jetty (without the Jetty
plug-in) using the standard java launcher that is available in Eclipse.
I use a slightly modified version of the Jetty project (I slightly
altered one of the base configs).  I also use a very simple ant build
script to merge J2 into my portal project.

If you like, I can put something together including instructions.
However, I am running close on my current project at work so it might be
a couple days before I can get anything to you.

-scott

> -----Original Message-----
> From: Eugene Fabrikant [mailto:eugene.fabrikant@bluenog.com]
> Sent: Tuesday, October 30, 2007 10:57 AM
> To: Jetspeed Users List
> Subject: Re: Running J2 in Eclipse
> 
> David Sean Taylor wrote:
> >
> > On Oct 28, 2007, at 12:21 PM, Eugene Fabrikant wrote:
> >
> >> Hello All,
> >>
> >> I've attempted to run Jetspeed in Eclipse as an imported web
project,
> >> with partial success.  I imported the portal build war and the
j2-admin
> >> portlets webapp as two separate web projects.  I proceeded to
modify
> the
> >> server.xml in the Eclipse server config to contain the appropriate
> >> context parameters.
> >>
> >> When I start the server from within Eclipse I'm able to get to the
> >> portal homepage, however the portlet windows all say "Portlet
> >> Application j2-admin not available".  The console reveals that the
> >> j2-admin webapp is initialized.  When I enable DEBUG level logging
in
> >> the j2-admin webapp, it says the following:
> >>
> >> 2007-10-28 15:16:46,345 [Timer-2] INFO
> >> org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/j2-
> admin]
> >>
> >> - JetspeedContainerServlet: attemping to start Portlet Application
at:
> >> j2-admin
> >> 2007-10-28 15:16:46,352 [Timer-2] INFO
> >> org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/j2-
> admin]
> >>
> >> - JetspeedContainerServlet: Could not yet start portlet application
at:
> >> j2-admin. Starting back ground thread to start when the portal
comes
> >> online.
> >>
> >> So it looks like it's not seeing the portal itself.
> >>
> >> Any ideas what this could be caused by?
> >>
> > Sounds like the Jetspeed webapp didn't start up
> > I edit and remote debug from within Eclipse all the time, never had
a
> > problem with it
> > In fact we provide .classpath with the project, but it requires that
> > you have a Maven-1 or Maven-2 local repository
> > Probably not optimal if you don't use Maven
> >
> >
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
> > For additional commands, e-mail:
jetspeed-user-help@portals.apache.org
> >
> We will do remote debugging if I can't get this to work, but I wanted
to
> try to do the portlet development completely within the context of the
> Eclipse IDE to avoid deployment cycles.  Our builds, however, are done
> using Maven-2.
> 
> If the Jetspeed webapp didn't start up, would I still be able to get
to
> the landing page without error?  Currently I'm getting a page with
four
> portlets, except the portlet contents only have the message "Portlet
> Application j2-admin not available".  According to the Eclipse
console,
> both the Jetspeed webapp AND the j2-admin webapps are started and
> initialized.
> 
> Thanks,
> 
> --
> Eugene Fabrikant
> Bluenog
> 
> 732-733-1120 x108 (w)         732-733-1139 (f)
> 973-722-4538 (c)              bluenogef (Y!IM, AIM)
> eugene.fabrikant@bluenog.com  www.bluenog.com
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-user-help@portals.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-user-help@portals.apache.org


Mime
View raw message